Faire la moyenne d'une plage de donnée, nombre de ligne variable

Résolu/Fermé
Signaler
Messages postés
17
Date d'inscription
mercredi 12 février 2014
Statut
Membre
Dernière intervention
9 mars 2016
-
Messages postés
17
Date d'inscription
mercredi 12 février 2014
Statut
Membre
Dernière intervention
9 mars 2016
-
Bonjour,

Je dois faire la moyenne de données, mais d'un mois à l'autre, le nombre de ligne peut changer. Je veux faire une macro qui sélectionnera les données à calculer.

- La première ligne (titre de la colonne) ne doit pas être sélectionnée
- Le résultat doit se placer dans le première cellule disponible de la colonne.

Ex: au mois de janvier, j'ai 12 lignes de données dont je dois faire la moyenne.
A1 = titre de la colonne
A2:A13 = données à calculée
A14 = résultat (moyenne de A2:A13)

Au mois de février, ce ne sera que 5 ligne
A1 = titre de la colonne
A2:A6 = données à calculée
A7 = résultat (moyenne de A2:A6)

Etc.

Ça peut sembler simple, mais je débute et là, je suis pris.

Un gros merci d'avance !!!

4 réponses

Messages postés
55111
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 décembre 2021
17 038
Sans macro, avec la moyenne en ligne 2 et les données à partir de la ligne 3, la formule =MOYENNE(A3:A999) devrait convenir.
Messages postés
17
Date d'inscription
mercredi 12 février 2014
Statut
Membre
Dernière intervention
9 mars 2016

Merci pour la réponse, mais mon problème, c'est que j'ai plusieurs moyennes à faire par feuille, j'aurait aimé une macro pour tout faire en un clic.

Comme le nombre de plages diffèrent d'un mois à l'autre, il faudrait que la macro sélectionne les plages où il y a des données et en fasse la moyenne.

Merci.
Messages postés
26323
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 décembre 2021
6 137
Bonjour
Pouvez vous dire, dans une seule feuille, ce qui permet de repérer les limites de plage à prendre en compte dans la moyenne?
et quelle est la façon dont sont renseignées les cellules dont il faut faire la moyenne?manuellement, ou par formule?
Sans info complémentaires, et si La moyenne en tête de colonne ne convient pas, difficile de vous aider, difficile de vous aider
crdlmnt
Messages postés
17
Date d'inscription
mercredi 12 février 2014
Statut
Membre
Dernière intervention
9 mars 2016

Mise en contexte:
Je dois calculer les statistiques téléphonique des employés du département. Il y a 10 catégories de statistiques (temps d'appel, nombre d'appels, etc) pour 3 catégories d'employés (analystes, conseillers et temps partiels)

Tout se fait sur la même feuille.
Rangée
1: titre des colonnes
2 à 6 : Analystes
7: résultat de la moyenne des stats analystes
8 à 15 : Conseillers
16: résultat de la moyenne des stats conseillers
17 à 19 : Employés à temps partiel
20: résultat de la moyenne des employés à temps partiel

Le problème, c'est que d'un mois à l'autre, le nombre d'employés peut varier (vacances, congés, maladies, mandats autres...)

Je sais comment aller me positionner dans la feuille (soit .select ou la fonction offset), c'est la sélection des plages contenant les valeurs à calculée qui me cause problème.

J'espère que c'est plus clair.