Excel Valeur cellule en ajoutant date dans différentes cellules

Résolu/Fermé
Signaler
Messages postés
9
Date d'inscription
lundi 20 janvier 2014
Statut
Membre
Dernière intervention
20 janvier 2014
-
Messages postés
9
Date d'inscription
lundi 20 janvier 2014
Statut
Membre
Dernière intervention
20 janvier 2014
-
Bonjour.

Dans mon chiffrier Excel j'aimerais avoir une cellule indiquant un statut au fur et à mesure que je remplis (sur la même ligne) des cellules avec des dates.

Par exemple, en L12 la cellule doit être vide (ou valeur "Nouveau") si M12, N12, O12 et P12 sont vides. Si j'ajoute une date dans M12 alors L12 doit afficher "Évaluation". Si j'ajoute une date dans N12 alors L12 doit afficher "Valide". Si j'ajoute une date dans O12 alors L12 doit afficher "Acceptée". Si j'ajoute une date dans P12 alors L12 doit afficher "Fermée".

En fait j'ai 16 valeurs/statuts différents.

Merci de votre collaboration

2 réponses

Messages postés
16538
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
6 décembre 2021
3 252
Bonjour

essaies
=SI(NB(M12:P12)=0;"nouveau";INDEX({"évaluation";"valide";"acceptée";"fermée"};NB(M12:P12)))

en supposant que tu remplisses bien dans l'ordre M,N,O,P

Tu peux aussi faire un tableau sur 2 colonnes (A:B pour l'exemple)
avec en col A A1=0,A2=1,A3=2... et en colonne B B1=nouveau, B2=évaluation... etc
=RECHERCHEV(NB(M12:P12);J2:K6;2;0)


tu pourrais obliger de respecter l'ordre avec une mise en forme conditionnelle
par ex en N12
=non(estvide(M12))
et tirer jusqu' à P12
Michel
Messages postés
9
Date d'inscription
lundi 20 janvier 2014
Statut
Membre
Dernière intervention
20 janvier 2014
1
Merci, c'est bon!