Récupérer le Nb de jour calculer avec =DIFFDATE(B3;C3+1;3)

[Résolu/Fermé]
Signaler
Messages postés
215
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
6 septembre 2020
-
Messages postés
215
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
6 septembre 2020
-
Bonjour,
Je voudrais récupérer les chiffres que donne la formule =DIFFDATE(B3;C3+1;3) dans 3 colonnes différentes

C'est à dire que si
B3=01/03/2013 et C3=31/08/2013 alors DIFFDATE(B3;C3+1;3) donne 0 an 6 mois 0 jour je voudrais récupérer 6 dans une colonne et 0 dans une autre
B3=04/05/2013 et C3=31/08/2013 alors DIFFDATE(B3;C3+1;3) donne 0 an 0 mois 28 jours
je voudrais récupérer 0 dans une colonne et 28 dans une autre
B3=013/04/2013 et C3=10/06/2013 alors DIFFDATE(B3;C3+1;3) donne 0 an 1 mois 29 jours
je voudrais récupérer 1 dans une colonne et 29 dans une autre
Merci d'avance pour votre aide



2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
538
Bonjour,

Si tu souhaites travailler avec EXCEL, je te conseille de regarder la fonction DATEDIF.
Pour utiliser DIFFDATE, il est préférable de regarder du coté d'ACCESS.
https://www.commentcamarche.net/faq/22460-difference-entre-dates-avec-la-fonction-datedif

A+
Messages postés
215
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
6 septembre 2020
14
Bonjour Gyrus,
J'avais bien commencé par là, mais cela me donnais des nb de Jours dépassant 31, or cela n'est pas possible...
J'ai quand même "replongée" sur ton lien et miracle....

Donc avec B3 pour la 1ère date et C3 pour la 2ème,
voici pour les mois (sachant que pour moi tout se passe sur 1 an)
=DATEDIF(B3;C3+1;"m")
et voici pour les jours
=SI(ET(JOUR(B3)=1;JOUR(C3)=JOUR(FIN.MOIS(C3;0)));0;SI(JOUR(B3)=JOUR(C3)+1;0;SI((B3)<(C3);(DATEDIF((B3);(C3);"md")+1);(DATEDIF((C3);(B3);"md")+1))))
pour les jours, il faut prendre en compte quand les 2 dates tombent sur des début et fin de mois SI(ET(JOUR(B3)=1;JOUR(C3)=JOUR(FIN.MOIS(C3;0)));0;
et quand les jours de date1 sont supérieur d'un jour à ceux de Date2 SI(JOUR(B3)=JOUR(C3)+1;0;
où les résultats doivent être 0.

Ouf je crois que cette fois-ci j'ai vu tous les cas possibles.
Merci Gyrus, quand on débute on appréhende toujours les calculs de date ou d'heures dans Excel...