Nombre de valeurs différentes selon 2 critères [Résolu/Fermé]

Signaler
Messages postés
116
Date d'inscription
vendredi 22 mai 2009
Statut
Membre
Dernière intervention
21 novembre 2013
-
Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
-
Bonjour à tous,

Me voici ce matin avec un problème de formule sur Excel :

Je souhaite compte le nombre de valeur différentes d'une colonne A, selon des critères en colonnes B (RP) et C (G3).

Voici un exemple de tableau :

A | B | C
_____|_____|_____
3206 | RP | G3 -> Oui
4156 | RP | G3 -> Oui
4156 | RP | G3 -> Non
4156 | RP | G4 -> Non
4208 | RP | G3 -> Oui
4221 | RP | G3 -> Oui
4157 | RP | G3 -> Oui
4159 | DZ | G1 -> Non

*Edit*, désolé, le tableau perd sa forme quand je publie.

J'ai testé 2 formules :

Matricielle :
{=SOMMEPROD(SIERREUR(($C$1:$C$8="G3")/NB.SI($A$1:$A$8;$A$1:$A$8);0);SIERREUR(($B$1:$B$8="RP")/NB.SI($A$1:$A$8;$A$1:$A$8);0))}


Et :

=SOMMEPROD((FREQUENCE((Dashboard!$B$1:$B$8="RP")*(Dashboard!$A$1:$A$8);(Dashboard!$B$1:$B$8="RP")*(Dashboard!$A$1:$A$8))>0)*1;(FREQUENCE((Dashboard!$C$1:$C$8="G3")*(Dashboard!$A$1:$A$8);(Dashboard!$C$1:$C$8="G3")*(Dashboard!$A$1:$A$8))>0)*1)-1

Le résultat devrait être 5, hors la formule m'indique 4 (car le "4156" est présent en G3 et G4 je crois).

Bien entendu mon tableau s'étend sur un grand nombre de lignes.

Merci d'avance, n'hésitez pas si je dois donner plus de détails.

Nicolas.

1 réponse

Messages postés
116
Date d'inscription
vendredi 22 mai 2009
Statut
Membre
Dernière intervention
21 novembre 2013
34
Après observation, j'ai trouvé mon erreur, je poste la solution au cas où cela pourrait aider quelqu'un dans le futur :

=SOMMEPROD((FREQUENCE((Dashboard!$B$1:$B$8="RP")*(Dashboard!$C$1:$C$8="G3")*(Dashboard!$A$1:$A$8);(Dashboard!$B$1:$B$8="RP")*(Dashboard!$A$1:$A$8))>0)*1)-1
Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
957
Bonjour,
Pour des valeurs numériques en A on peut aussi adapter la formule matricielle:
=NB(1/FREQUENCE(SI((B1:B10="RP")*(C1:C10="G3")=1;A1:A10);A1:A10))
À valider avec ctrl+shift+enter.