Calculer l'âge quelle qu'elle soit le format de la date [Résolu/Fermé]

Signaler
Messages postés
110
Date d'inscription
samedi 30 juin 2007
Statut
Membre
Dernière intervention
30 septembre 2017
-
 Zonte -
Bonjour,

dans une liste les dates de naissance ne sont pas toujours écrites sous le même format.parfois il y a le jour le mois et l'année(ex 03/12/1998) et parfois il n'y a que l'année(4 chiffres)y a-t-il une formule qui calcule l'âge en prenant en compte les deux formats de dates ?
merci


6 réponses

Messages postés
25404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020
5 541
Bonjour
l'année seule étant une valeur numérique très basse pour Excel, vous pouvez toujours essayez cette formule


=ANNEE(AUJOURDUI()-SI(A1>3000;A1;ANNEE(A1))

qui ne vous donnera pas l'age exact, mais le nombre d'année entre les deux valeurs.
(3000 représetant l'année 1908 pour Excel)
Crdlmnt
Errare humanum est, perseverare diabolicum
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
2955
Date d'inscription
lundi 18 septembre 2006
Statut
Membre
Dernière intervention
31 août 2019
194
en vba access j'utilise ceci

age:[Date]-[ChampDateNaissance]/365,25
Date est une fonction
Access donne le resultat en jour
Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
4 297
Bonjour le fil,

Bonjour Vaucluse, tu es tombé du lit ? déjà opérationnel !

il doit y avoir certainement de dates au format texte, le plus simple serait de mettre un exemple de fichier avec les différent type de date sans donnée confidentielle que tu peux joindre avec ce lien

https://www.cjoint.com/

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
25404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020
5 541
Saut Mike
tomber du lit pour une bonne cause oui... je pars trois semaines dire bonjour au requin de la Réunion!

Bon courage à ceux qui bossent. Accrochez vous!

Bien amicalement
Messages postés
110
Date d'inscription
samedi 30 juin 2007
Statut
Membre
Dernière intervention
30 septembre 2017

bonjour à tous
je joins un fichier pour être clair
merci
https://www.cjoint.com/c/CKbitkUnJqQ
Messages postés
17258
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 octobre 2020
4 297
Re,

le problème avec ce genre de saisie est que l'âge sera calculé à partir du 1er janvier même si la personne est née en fin d'année, disons que la personne aura l'age affiché dans l'année, avec cette formule en E6 et incrémente vers le bas

=SI(NBCAR(D6)>4;ANNEE(AUJOURDHUI())-ANNEE(D6);ANNEE(AUJOURDHUI())-D6)

pour éviter le calcul en fonction de cellule vide utilise plutôt cette formule

=SI(D6="";"";SI(NBCAR(D6)>4;ANNEE(AUJOURDHUI())-ANNEE(D6);ANNEE(AUJOURDHUI())-D6))
J'ai le meme problème mais je veux le code en VBA
Messages postés
110
Date d'inscription
samedi 30 juin 2007
Statut
Membre
Dernière intervention
30 septembre 2017

salut
les deux applications marchent très bien.
merci