Fonction sommeprod [Résolu/Fermé]

Signaler
Messages postés
1
Date d'inscription
samedi 26 octobre 2013
Statut
Membre
Dernière intervention
26 octobre 2013
-
Messages postés
26002
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mai 2021
-
Bonjour,

Dans quel cas utilisez-vous cette fonction ?

1 réponse

Messages postés
26002
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mai 2021
5 909
Bonjour

.... ben en cas de besoin!

Le code SOMMEPROD étant utilisable dans de nombreux cas de figures, difficile de répondre à cette question

Pour info de base:
SOMMEPROD sert à déterminer un nombre d'item répondant pour un champ complet, à une série de conditions par colonne, réalisées sur la même ligne.
Elle permet soit de compter les items répondants à l'ensemble des conditions , soit de sommer une colonne selon ces items.


Principe:

le code affecte 1 à chaque item réalisé, 0 sinon, multiplie les résultats et additionne les 1 résultants, ou les valeurs du champ si une somme est demandée

Par exemple:

=SOMMEPROD((A1:A100=1)*(B1:B100="A")*(C1:C100="xxx"))
va compter combien de lignes répondent à A=1;B=A et C =xxx

=SOMMEPROD((A1:A100=1)*(B1:B100="A")*(C1:C100="xxx")*(D1:D100))
va faire la somme des valeurs (numériques) de D selon ces items

L'avantage majeur de SOMMEPROD est d'être matricielle (sans les contraintes d'entrées par 3 touches) et de permettre donc de "décomposer" des conditions comme par exemple:
=SOMMEPROD((GAUCHE(A1:A100;2)="xx")*(MOIS(B1:B100)=8) ect....

Mais ce n'est qu'un petit aperçu de l'ensemble des possibilités.

crdlmt
Errare humanum est, perseverare diabolicum