Erreur #DIV/0! [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
jeudi 10 octobre 2013
Statut
Membre
Dernière intervention
10 octobre 2013
-
Messages postés
3
Date d'inscription
jeudi 10 octobre 2013
Statut
Membre
Dernière intervention
10 octobre 2013
-
Bonjour à tous,

J'ai un petit soucis avec l'erreur #DIV/0!.

Je m'explique: je dois calculer le taux d'évolution de soldes de comptes comptables d'un mois sur l'autre (plus d'une centaine).

Dans toute cette liste de compte, certains:
- n'ont pas de solde connu et donc la formule ((B2-A2)/A2) renvoie une erreur #DIV/0!
- ont un solde à 0 mois après mois et donc la formule renvoie une erreur #DIV/0!
- ont un solde à 0 en janvier, et un solde positif en février, ici aussi la formule renvoie une erreur #DIV/0!

Dans cette liste les deux premiers cas ne m'intéressent pas, j'aimerai donc les masquer (mise en forme conditionnelle ou formule esterreur).

C'est le troisième cas qui est très important pour moi, or je n'arrive pas à ET masquer l'erreur dans les deux premiers cas, ET laisser apparent le troisième cas.

J'espère avoir été clair et m'excuse pour d'avance ce pavé...et je vous remercie par avance pour vos réponses :)

3 réponses

je pense qu'il faut que vous modifiez votre formule en intégrant une formule si.

en mettant si "la cellule que vous voulez prendre en référence >0; B2-A2/A2;0)

moi je mettrais ça :
en admettant que votre cellule référence soit A2 :
=(siA2>0;B2-A2/A2;0)

je ne suis pas sûre mais vous pouvez toujours tester si ça marche.
Messages postés
3
Date d'inscription
jeudi 10 octobre 2013
Statut
Membre
Dernière intervention
10 octobre 2013

Bonjour Zalyrr, et merci pour votre le réponse,

le problème avec cette formule est qu'elle me donne un résultat = à 0 pour une évolution de 0 à 100
Messages postés
3
Date d'inscription
jeudi 10 octobre 2013
Statut
Membre
Dernière intervention
10 octobre 2013

On m'a donné cette solution (appliquée à mon cas):

=SI(ET(D2=0;C2=0);"Néant";
(SI(ET(D2=0;C2<>0);"Soldé";
(SI(ET(D2<>0;C2=0);"Attention!";
(SI(ET(D2=C2);"Néant";((D2-C2)/C2))))))))