Excel 2003: menu déroulant

[Fermé]
Signaler
-
Messages postés
17509
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
1 septembre 2021
-
Bonjour,

Dans Excel 2003:

J'utilise des menus déroulants pour compléter la majorité des cellules d'un formulaire.

Est-il possible qu'un menu déroulant situé (par exemple) en cellule C5 entraine l'apparition d'une information dans une autre cellule?

Merci pour votre aide

9 réponses

Messages postés
17509
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
1 septembre 2021
4 705
Bonjour,

Oui bien sur, en cellule C5 ta liste de validation ensuite tout dépend de ce que tu souhaites afficher
si tu souhaites donner une valeur à ce que tu sélectionnes
=si(C5="x";10;si(C5="y";5;si(C5="w";2;0)))

ou tu veux afficher une valeur existante dans un tableau et dans ce cas tu utiliseras la fonction RECHERCHEV

=RECHERCHEV(C5;plage de recherche;colonne de recherche;0)
ce qui peut donner pour une plage de recherche A1:F4 colonne B
=RECHERCHEV(C5;A1:F4;2;0)

pour une réponse adaptée il faudra nous en dire plus
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
54536
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 septembre 2021
16 467
Bonjour ar168.

Veux-tu parler de
Menus déroulants (avec Contrôles de formulaire) ou de
Liste déroulante de cellule (avec Données/Validation des données/Liste) ?
Merci pour vos réponses.

Il s'agit de listes déroulantes (désolé pour le lapsus...)

Le classeur est disponible:
http://cjoint.com/?3Jgw0J1kFSf

En B4, j'ai la liste des classes.
Je voudrais qu'en choisissant une classe, le nombre d'élèves apparait en C7

A nouveau, merci pour l'aide apportée.
Messages postés
54536
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 septembre 2021
16 467
J'ai beau regarder, je ne vois pas le tableau où figurent les effectifs des classes ...
Messages postés
17509
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
1 septembre 2021
4 705
Re,

sur le fichier que tu as joint, onglet com, la liste des classes est en B3, pas en B4
en B4 tu as la liste des profs
ensuite dans quel onglet et colonne as tu le nombre d'élèves ?

mon premier post avec la fonction RECHERCHEV répond à tes attentes
en supposant que la matrice se trouve onglet source et colonne O

=RECHERCHEV(B3;source!I2:P300;8;0)

si tu nommes la matrice "source!I2:O300" par exemple "list"
la formule devient
=RECHERCHEV(B3;list;8;0)

dommage que ton fichier ne soit incomplet
Autre problème sur ton fichier, évite d'utiliser les bordures sur la totalité de la feuille (1 048 576 lignes et 16 384 colonnes) cela alourdi inutilement le fichier

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
La liste des classes en bien en B3. La fatigue me guette!

J'ai modifié le classeur: l'effectif est sous l'onglet "source" en colonne P (les classes étant en I)

Lien: http://cjoint.com/?CJgxtlpvB4T

Merci et a+
Messages postés
17509
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
1 septembre 2021
4 705
Regarde mon dernier post que j'ai actualisé

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Bonjour,

J'ai enfin eu le temps de me pencher sur mon classeur.

Dans la formule =RECHERCHEV(B3;list;8;0) à quoi correspond 8;0 ?

Merci
Messages postés
17509
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
1 septembre 2021
4 705
Re,

=RECHERCHEV(B3;list;8;0)

=RECHERCHEV( nom de la fonction

B3; cellule contenant le critère recherché

source!I2:P300 ou list est la matrice de recherche, I la colonne contenant le critère recherché

8; est la huitième colonne de ta matrice soit la colonne P

0) ou FAUX) renvoi 0 si la condition n'est pas remplie ou dans un ordre aléatoire, si tu ne mets pas en fin de formule 0) ou FAUX) la formule retournera FAUX