Imbrication de la fonction "SI" avec un résultat de recherche [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 14 août 2013
Statut
Membre
Dernière intervention
16 août 2013
-
Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
-
Bonjour,
Je m'excuse de vous déranger, mais je suis bloqué dans Excel et je n'arrive pas à formuler ma fonction de sorte à obtenir le résultat voulu

J'ai créé cette fonction
=SI(ESTVIDE(Y3);0;1)*(RECHERCHEV(Y3;Bases!$A$3:$B$13;2))

Le but c'est qu'excel cherche dans la case Y3. Si celle ci est vide il doit m'indiquer 0
Pour les cases où il y a quelque chose, il doit aller chercher dans la base correspondante la valeur et me la reporter. Et ainsi comme il me la multiplie par 1 la valeur n'est pas faussée

Avec cette fonction, quand il y a bien quelque chose dans la case Y, pas de soucis il me met comme prévu ce qui correspond
Mais quand il n'y a rien il m'indique N/A car il calcule 0* "un truc qui n'existe pas"

Ce que je voudrai dire à Excel c'est "si y'a pas de valeur dans la case Y, tu t'embêtes pas à me chercher une liste qui du coup n'existera pas et tu me mets directement 0". Le tout dans une fonction qui est valable pour les deux cas de figure (avec valeur existante ou pas)

Merci d'avance à tous et toutes car je bloque

2 réponses

Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
146
Bonjour,

=SI(ESTVIDE(Y3);0;RECHERCHEV(Y3;Bases!$A$3:$B$13;2))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
mercredi 14 août 2013
Statut
Membre
Dernière intervention
16 août 2013

Juste pour vous remercier c'était exactement ça
Donc si je comprends bien en mettant un point virgule vous avez donné à Excel un ordre de priorité dans ses opérations ?

Encore merci :)
Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
146
bonjour,

non il ne s'agit pas d'une priorité

si est vide Y3 ==> zffiche <à
si Y3 n'est pas vide, fait la recherche.