Recherche d'une valeur supérieur la plus proche

Résolu/Fermé
redw79
Messages postés
11
Date d'inscription
mercredi 24 juillet 2013
Statut
Membre
Dernière intervention
25 janvier 2016
- 24 juil. 2013 à 15:16
ccm81
Messages postés
10418
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
11 août 2022
- 24 juil. 2013 à 16:18
Bonjour,

j'ai une valeur calculer E1, et j'ai un tableau avec plusieurs valeur A1<A2<A3<A4<A5, la valeur E1 est entre les deux valeur A3 et A4, et E1 est proche de la valeur A3 mais moi je veux qu'il m'affiche la valeur A4 (la valeur supérieur la plus proche)

merci d'avance.
A voir également:

1 réponse

ccm81
Messages postés
10418
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
11 août 2022
2 306
24 juil. 2013 à 15:25
Bonjour

si la valeur en E1 ne peut pas être égale à l'une des valeurs de A1:A5
=INDEX(A1:A5;EQUIV(E1;A1:A5;1)+1)

sinon
=SI(ESTNA(RECHERCHEV(E1;A1:A5;1;0));INDEX(A1:A5;EQUIV(E1;A1:A5;1)+1);RECHERCHEV(E1;A1:A5;1;0))

Bonne journée
0
redw79
Messages postés
11
Date d'inscription
mercredi 24 juillet 2013
Statut
Membre
Dernière intervention
25 janvier 2016

24 juil. 2013 à 15:52
Merci beaucoup pour votre aide
0
ccm81
Messages postés
10418
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
11 août 2022
2 306
24 juil. 2013 à 16:18
RQ. si E1<A1 il y a un message d'erreur, il te suffit d'ajouter un test pour régler ce problème

si c'est bon, peux tu mettre le problème à résolu (en haut à droite de ton premier post)

cdlmt
0