Formule SI Excel 2007 [Résolu/Fermé]

Signaler
-
Messages postés
12247
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
10 février 2021
-
Bonjour

une autre question concernant le fichier... J'ai des calculs à faire = B3/(B3+B5+B7)... Je voudrais qu aucune valeur ne s'affiche si :
- B3/(B3+B5+B7) =0
=SI((B3/(B3+B5+B7)=0);"";B3/(B3+B5+B7))
- (B3+B5+B7) = 0 sinon cela m'affiche #DIV/0
=SI(ESTERREUR(B3/(B3+B5+B7)=VRAI);"";B7/(B3+B5+B7))
j'arrive à faire les conditions séparées mais pas ensemble...

J'ai essayé cette formule mais ça m'affiche toujours le #DIV/0
=SI(OU((B3/(B3+B5+B7)=0);ESTERREUR(B3/(B3+B5+B7)=VRAI));"";B3/(B3+B5+B7))

Au secourrrrrrrrr

Merci d'avance pour vos réponses

2 réponses

Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
167
Bonjour,
Pourquoi ne pas faire plus simplement, comme ceci par exemple :

=SI(B3+B5+B7=0;"";B3/(B3+B5+B7))


-------------------
Cordialement,
Clément
Messages postés
12247
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
10 février 2021
2 575
Bonjour Mogothal.
J'ajouterais ceci :
SI B3=0 et que B5 = B7 = 2 alors ta formule revoie 0.
or, si j'ai bien compris, le demandeur veut que rien ne s'affiche.
Donc :=SI(OU(B3=0;B3+B5+B7=0);"";B3/(B3+B5+B7))
Qu'en penses tu?
Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
167
Salut Pijaku,
C'est pas faux, avec cette précision :
Je voudrais qu aucune valeur ne s'affiche si : B3/(B3+B5+B7) =0 , donc également si B3 = 0

Ta formule est la bonne :-)
=SI(OU(B3=0;B3+B5+B7=0);"";B3/(B3+B5+B7)) 
Messages postés
12247
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
10 février 2021
2 575
Donc nous sommes d'accords.
C'est résolu.
Merci beaucoup...

C'etait d'une simplicité, mais on cherche toujours à faire compliqué...

Bonne fin de journée
Messages postés
12247
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
10 février 2021
2 575
Merci à toi.
Bonne fin de journée également.
A+