Extraire le mois à partir d'une date et d'une heure sur xls [Résolu/Fermé]

Signaler
Messages postés
16
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
5 juillet 2013
-
 Carlita7 -
Bonjour,

Je débute sur xls et je souhaite extraire le mois à partir d'une cellule xls qui contient la date et l'heure :
23/06/13 16:14:43 --> juin.

Est-ce possible ?
Merci par avance.
Slts,
Carlita7

8 réponses

Messages postés
346
Date d'inscription
mardi 7 octobre 2008
Statut
Membre
Dernière intervention
2 juin 2015
109
Salam carlita.

Si ta date est en cellule A1 et que tu veux extraire le mois en cellule B1, alors tape la formule suivante en B1: =MOIS(A1) et tu obtinendras le numéro du mois (par exemple 6 pour le mois de juin).

:)
Messages postés
16
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
5 juillet 2013

En fait, en lisant les messages du forum, j'ai trouvé ma réponse, la voici :
=TEXTE(30*MOIS(A4);"mmmm") et ça fonctionne !

Carlita7
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
6 458
pourquoi multiplier par 30 ???
eric
Messages postés
16
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
5 juillet 2013

Bonjour Redaiwa,

Merci pour ta réponse.
J'avais effectivement trouvé ce que tu me proposes mais je voulais le mois en lettre et non en chiffre pour éviter de créer une colonne supplémentaire pour passer de 6 à juin.

Merci.
Carlita7
Messages postés
16
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
5 juillet 2013

J'ai repris la formule telle qu'elle. Je suppose que 30 correspond à 30 jours du mois.
Carlita7
Messages postés
16
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
5 juillet 2013

Tu penses que cette formule ne peut pas toujours fonctionner ?
Carlita7
Messages postés
346
Date d'inscription
mardi 7 octobre 2008
Statut
Membre
Dernière intervention
2 juin 2015
109
Bravo Carlita7.
Tu m'apprends quelque chose !
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
6 458
Tu penses que cette formule ne peut pas toujours fonctionner ?
Restons simples, utilise :
=TEXTE(A4;"mmmm")

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
6 458
essaie encore, fais un copié-collé de la formule.
eric
Messages postés
16
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
5 juillet 2013

En effet, je confirme que mes mois sont triés alphabétiquement dans mon TCD donc j'ai appliqué la formule qui fonctionne maintenant : =TEXTE(A1;"aaaa-mm"). Dommage que le tri soit alphabétique et non par mois croissant.
Demain, j'essaierai de voir ce que je peux faire avec les regroupements sur les TCD et les dates.

Merci.
Carlita7
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020
6 458
>
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020

Merci pour l'exemple, je testerai demain matin.
Slts,
Carlita7
>
Messages postés
23630
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 novembre 2020

Merci pour l'exemple, je testerai demain matin.
Slts,
Carlita7