Nombre de fin de mois entre deux dates

[Résolu/Fermé]
Signaler
-
Messages postés
211
Date d'inscription
vendredi 10 mai 2013
Statut
Membre
Dernière intervention
22 octobre 2016
-
Bonjour, je souhaiterais calculer le nombre de mois échus entre deux dates, existe-t'il une formule qui fasse ça?, j'ai essayé DATEDIF mais ça ne correspond pas à ma demande. Ex : du 16/04/2012 au 30/04/2012 = 1 et DATEDIF trouve 0, par avnce merci de votre aide.




2 réponses

Messages postés
211
Date d'inscription
vendredi 10 mai 2013
Statut
Membre
Dernière intervention
22 octobre 2016
71
Bonjour,

L'exemple que tu donnes est un cas particulier puisque la date de fin correspond au dernier jour du mois.

Avec la date de début en A1 et la date de fin en A2, la formule suivante devrait faire ce que tu veux : =SOMME(DATEDIF(A1;A2;"m");SI(A2=FIN.MOIS(A2;0);1;0))

Elle permet de traiter le cas particulier de ton exemple.

Bonne journée !
Merci pour cette rapidité, cela fonctionne au poil si....... on ne dépasse pas 12 mois, mais grâce à ta formule j'ai pu m'en sortir en la déclinant pour qu'elle puisse être transportée au delà des 12 mois.
=SI(ANNEE(A2)=ANNEE(A1);SOMME(MOIS(A2)-MOIS(A1);SI(A2=FIN.MOIS(A2;0);1;0));SOMME(MOIS(A2)-MOIS(A1);SI(A2=FIN.MOIS(A2;0);1;0))+(ANNEE(A2)-ANNEE(A1))*12). ça fait un peu barbare je pense qu'il y a plus court mais ça marche!
@ +
Messages postés
211
Date d'inscription
vendredi 10 mai 2013
Statut
Membre
Dernière intervention
22 octobre 2016
71
Tu as raison, j'aurais dû rester sur ta formule de base avec DATEDIF. J'ai modifié ma réponse ci-dessus pour qu'elle devienne correcte même au-delà des 12 mois.