Fonction SI à 3 conditions [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 19 avril 2013
Statut
Membre
Dernière intervention
20 avril 2013
-
Messages postés
9820
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
27 novembre 2020
-
Bonjour,

Je suis entrain de faire un tableau et j'ai 1 problème :

J'ai 3 cases blanches (ont va les appeler A, B et C) qui seront remplis dans un ordre indéterminé, je souhaite donc obtenir des résultats quelque soit l'ordre de remplissage des cases, j'ai donc pour le moment :

Un résultat pour que A de rempli
Un résultat pour que B de rempli
Un résultat pour que C de rempli
Un résultat pour A, B et C de remplis

J'utilise donc la fonction SI dans le but d'obtenir un résultat dans le cas où 2 cases sont remplies par exemple :

=SI(A="";SI(B="";SI(C="";"1";SI(A="");"2";"3"))))

Le résultat "1" est le résultat lorsque que les 3 cases sont vides.
Le résultat "2" est le résultat lorsqu'il ne manque que A
Le résultat "3" serait le résultat final.

Le problème est donc que 2 et 3 ne s'affiche pas et me marque FAUX, et je n'arrive pas a y remédier, si besoin du fichier, je l'enverrais par message privé tronqué (car une partie confidentielle).

Merci d'avance pour une éventuelle solution.

7 réponses

Messages postés
3
Date d'inscription
vendredi 19 avril 2013
Statut
Membre
Dernière intervention
20 avril 2013

Je pense avoir trouver moi même une solution :

Mettre
=SI(A="";SI(B="";SI(C="";"1";SI(A="");SI(B=x);SI(C=y);"2";"3"))))

Seulement je ne sais pas comment faire en sorte que B et C soit considéré comme remplis quelque soit le chiffre qui sera mis dedans. Quoi mettre à la place de x et y en gros.

Voici le fichier si cela permet de mieux comprendre ma demande : https://www.cjoint.com/?0DtqlpK9MlI

Si quelqu'un arrive à faire fonctionner une des 3 lignes, même avec des chiffres tels que 1 2 3

Merci
Messages postés
9820
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
27 novembre 2020
1 097
Bonjour,
Est-ce que cela est correct : https://www.cjoint.com/?3DtxPT89Wa2

Messages postés
52772
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
14 698
Bonjour à tous les deux.
Dis, Pupo57 : Pourquoi toutes ces complications inutiles ?
* 1) Quand tu écris en E4 la formule =MOYENNE(B4:D4) excel fait le nécessaire, en divisant la somme B4:D4 par le nombre de notes, ce qui remplace avantageusement ta formule =SI(D4="";((B4+C4)/2);((B4+C4+D4)/3)) qui contient d'ailleurs des paren-thèses inutiles, =SI(D4="";(B4+C4)/2;(B4+C4+D4)/3) fonctionnant aussi bien ...
* 2) Je comprends bien qu'en J4 dans ta formule
=SI(I4="";((0,6*F4+G4*0,6)/1,2);((0,6*F4+G4*0,6+H4*0,9+I4*0,9)/3))
tu aies besoin de pondérer les notes en F4, G4, H4 et I4 ; mais tu aurais pu (et dû) remplacer (0,6*F4+G4*0,6)/1,2) par (F4+G4)/2) et écrire ta formule
=SI(I4="";(F4+G4)/2;(0,6*(F4+G4)+0,9*(H4+I4))/3)
* 3) De la même manière, en U4, pas la peine de conserver
=SI(T4="";((S4*0,75)/0,75);((S4*0,75+T4*3,25)/4))
même si au départ cela te permettait de suivre la logique de ton raisonnement, quand on peut se contenter d'écrire
=SI(T4="";S4;(S4*0,75+T4*3,25)/4)
Tu me diras "Ce n'est pas grave" ; mais si ta ligne 4 est répétée pour les 35 élèves de la classe ou les 90 élèves de la division, cela vaut la peine d'optimiser tes formules.
* 4) Si j'ai bien compris, toutes les notes sont sur 20, donc les moyennes aussi. Alors normalement la moyenne générale devrait être =(E4+J4+N4+R4+U4)/5
Quel besoin de pondérer par matière, et de plus selon le nombre de notes de chaque matière ? C'est une règle qui t'est imposée ?
C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
Messages postés
52772
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
14 698
... et pour répondre très précisément à ta question "comment faire en sorte que B et C soit considéré comme remplis quelque soit le chiffre qui sera mis dedans. Quoi mettre à la place de x et y en gros" tu peux remplacer, au choix,
SI(B=x);SI(C=y);"... par
SI(B<>"");SI(C<>"");"... ou par
SI(ESTNUM(B));SI(ESTNUM(C));"... ou encore par
SI(NB(B)=1;SI(NB(C)=1;"...
Tu peux tester toutes ces solutions.

Cordialement.
Messages postés
52772
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
14 698
... enfin, pour remonter au tout début de tes interventions, tu as exposé des choses contradictoires :
Un résultat pour que A de rempli
Un résultat pour que B de rempli
Un résultat pour que C de rempli
Un résultat pour A, B et C de remplis

J'utilise donc la fonction SI dans le but d'obtenir un résultat dans le cas où 2 cases sont remplies par exemple :
=SI(A="";SI(B="";SI(C="";"1";SI(A="");"2";"3"))))
Le résultat "1" est le résultat lorsque que les 3 cases sont vides.
Le résultat "2" est le résultat lorsqu'il ne manque que A
Le résultat "3" serait le résultat final
.

Ne sachant pas exactement ton besoin, et pour que tu puisses bien voir comment s'enchaînent les fonctions SI imbriquées, je t'ai préparé un logigramme exhaustif, qui balaie tous les cas de figure et exécute 7 tests pour proposer les 8 réponses possibles. J'ai pu situer les cas 1 et 2 évoqués ; je ne sais pas lequel correspond à ton cas 3 ... https://www.cjoint.com/c/CDucI4MjlCi

Cordialement (je me suis bien amusé !)
C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
Messages postés
3
Date d'inscription
vendredi 19 avril 2013
Statut
Membre
Dernière intervention
20 avril 2013

Bonsoir,

Merci pour toutes ces réponses, j'en attendais pas autant.

Je vais regarder et éditer ce message au fur et à mesure.

Edit : Le Pingou, c'est exactement cela, je vais donc me pencher dessus pour comprendre la méthode que vous avez utiliser, merci.

Raymond, je vais répondre point par point pour plus de clarté :
1) Le surplus de parenthèses est l'un de mes principales défauts, toujours à en mettre trop, que je préfère à pas assez, bien que ça me complique plus la vie qu'autre chose au final.
2)Autant sur le papier, je penche à en faire le moins possible, autant sur excel, j'ai carrément l'inverse, je vais essayer de continuer à le travailler, comme le 1)
4) Car chaque sous moyenne à son propre coefficient, bien que 3 soit identique, mais je pense que la simple utilisation de la fonction Moyenne devrait suffire.


SI(B<>"");SI(C<>"");"... ou par
est donc le contraire de "", j'ai chercher sans trouver, surement de mauvais mots clés ou de façon à me faire comprendre.

En ce qui concerne le logigramme, je l'avais fait sur papier pour m'éclairer sinon je me perdais trop vite, mais merci tout de même.


Donc pour conclure, je vous remercie tout les deux, j'ai pu apprendre pas mal de nouvelles choses rapidement et je vais essayer de le refaire de moi même avec toutes ces choses apprises.

Encore merci.
Messages postés
9820
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
27 novembre 2020
1 097
Bonjour,
Merci pour l'information.
Petit encas avec une deuxième solution : https://www.cjoint.com/?3DvoyxMX7XP