Recherche Formules ou Macro pour Recherchev & condition

Fermé
Signaler
Messages postés
2
Date d'inscription
mercredi 17 avril 2013
Statut
Membre
Dernière intervention
17 février 2014
-
Messages postés
5803
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
24 janvier 2022
-
Bonjour,

J'ai un exemple de tableau excel que je souhaiterais créer comprenant un ensemble de cellules fermes (mes données de travail que je dois figer) situées de A1 à A25 (données qui vont évoluées sur 5 ou 6cycles sur l'année)

Tous les jours, je dois comparer ce tableau (gris) a un autre tableau (bleu), issue d'une requête access, et de forme identique que le 1er.

Le but du jeu (si je peux le dire) est de m'assurer que :
- toutes les commandes de la colonne A sont bien celles de la colonne I
- toutes les dates de livraison de la colonne E (en fonction de son numéro de commande, colonne A) sont identiques à celles de la colonne N (en fonction de son numéro de commande également colonne I)

Je ne sais pas si je suis très clair mais je souhaiterais savoir sil est possible d'automatiser par une formule et/ou macro pour me permettre de vérifier mes données.

De plus Je souhaiterais savoir aussi s'il existe de nouvelles commandes (colonne I) qui ne sauraient pas dans mes données fermes.

Je n'ai pas d'impératif pour incrémenter 1 ou plusieurs colonnes pour visualiser le résultat.

A votre disposition si besoin de plus d'information.

Merci bcp pour votre aide.

Kevin


Désole je n'arrive pas à envoyer mon fichier

1 réponse

Messages postés
5803
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
24 janvier 2022
687
Bonjour

Avec un contrôle placé dans une nouvelle colonne

=SI(NB.SI.ENS($A$1:$A$25;$I1;$E$1:$E$25;$N1);1;0)
la cellule n'étant pas en concordance sera à 0 (zéro)

Contrôle les commandes en A avec chaque cellule de I
puis les dates en E avec chaque date en N

espèrant avoir répondu à votre besoin
0