Mettre une couleur à une cellule grâce à la fonction SI [Résolu/Fermé]

Signaler
-
 Arya -
Bonjour,

je travaille actuellement sur un fichier excel 2007.
Ma dernière colone est sous forme de menu déroulant avec 3 possibilités :
- 4 fichiers séparés mais accéssibles
- 1 fichier commun
- Fichiers séparés non accéssible

J'aimerais qu'en fonction de ce que je choisi dans ma dernière colonne la toute première devienne (dans l'ordre des 3 possibilités ci-avant) orange, rouge, verte.

Je bloque dessus depuis un moment donc si vous avez la solution ce serait génial !

3 réponses

Messages postés
25333
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
Bonjour

ce qui serait génial pour débuter, c'est d'être un peu plus précis dans vos explications.
Les 3 positions que vous annoncez sont quoi? des textes dans les cellules?

crdlmnt
Non il faudrait que ce soit une couleur.
Il faudrait que la cellule se colorie automatiquement en fonction de ce que je choisi dans le menu déroulant
Messages postés
25333
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
Ben oui ça j'ai compris, mais c'est quoi les textes de votre menu?
du menu déroulant ? je les ai noté juste en dessous : 4 fichiers séparés mais accéssibles, 1 fichier comme et Fichiers séparés
Messages postés
25333
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
Alors voir la solution de Via ci dessous. qui est très correcte (comme d'hab) _avec toutefois la remarque qu'il n'est pas utile, voire néfaste dans certains cas, d'utiliser la condition SI dans une MFC de ce type,(puisque la MFC est déjà une condition)
Mais attention, si vous placez les formules comme il le recommande, faites bien les mêmes fautes d'orthographe :-))

Soit donc la formule:
=F2="texte rigoureusement identique" entre guillemets

Sinon vous pouvez utiliser pour éviter le risque et selon son exemple , (à condition que les références du menu déroulant soient sur la même feuille)
=F2=cell du menu déroulant correspondante au texte

crdlmnt
Merci beaucoup pour l'aide !!
Messages postés
12724
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 octobre 2020
2 028
Bonsoir,

Supposons les données sur une plage A2:F40, les choix étant donc dans la colonne F

Sélectionner la plage A2:A40
MFC
Nouvelle regle
Utiliser une formule
et entrer la formule
=SI(F2="4 fichiers séparés mais accéssibles")
avant de choisir la couleur orange et de valider

Recommencer 2 fois l'opération pour les autres conditions en changeant critères et couleur

Cdlmnt
Merci pour l'aide vous géré !