Recherchev dans 2 feuilles différentes si un = n/a

[Résolu/Fermé]
Signaler
-
Messages postés
3
Date d'inscription
jeudi 21 mars 2013
Statut
Membre
Dernière intervention
25 mars 2013
-
Bonjour,

J'ai un fichier excel dans lequel je dois utiliser la recherchev pour trouver des prix. J'ai deux différentes feuilles dans lequel il doit aller voir pour les prix. S'il trouve pas dans la première feuille il doit aller voir dans la deuxième. J'y arrive simplement pas.
J'ai fait pas mal de recherche et essaie avec Si(esterreur(recherchev et ca fonctionne pas)
J'aurais vraiment besoin d'aide svp.


sur la feuille 1 j'ai mes numéro de code en A1 sur ma feuille 2 c'est ma bd principale dans laquelle je vais chercher le prix de l'article selon le code en A1 sur la feuille 1, si le résultat est N/A ca veut dire qu'il ne l'a pas trouvé, alors la je veux qu'il est voir dans ma feuille 3 pour rammener le prix qui est dans la colonne 3


MErci

Nancy


2 réponses

Messages postés
13097
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2021
2 245
Bonjour

Ca devrait fonctionner pourtant

Voilà un exemple qui marche :
https://www.cjoint.com/?3CvqUBbe6hK

A adapter à ton cas

Cdlmt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
26182
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 septembre 2021
6 052
Bonjour tous

Pour info seulement sachant que la solution de Via est très correcte, mais pour faire un peu plus court: selon son modèle

=RECHERCHEV(B3;SI(NB.SI(Feuil2!B:B;B3);plage1;plage2);2;0)

Crdlmnt
Messages postés
13097
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2021
2 245
Bonjour Vaucluse

Astucieux, je note !

Bien cdlmnt
Messages postés
3
Date d'inscription
jeudi 21 mars 2013
Statut
Membre
Dernière intervention
25 mars 2013

Merci beaucoup, il me manquant le dernier argument.

Merci pour votre aide.

Nancy