NbVal sauf si valeur 0 [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013
-
Messages postés
9
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013
-
Bonjour à tous,

Désolé j'ai encore une autre question.

J'ai une colonne avec du Texte si je fais dans la colonne juste à côté =nbval(B25) il me met "1" et c'est ce que je veux. Mais parfois j'aui le chiffre "0" et la je voudrai qu'il me mette rien ou alors 0.

DOnc est ce possible de faire nbval si différent de "0"

Merci par avance !


4 réponses

Messages postés
9
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013
1
Je n'y arrive pas, mais je me suis mal expliqué.

J'ai en case C25 du texte qui peut etre de 6 formes de texte différents ou le chiffre "0"

En case E25 je voudrais le chiffre "1" si Texte en C25 et "0" si chiffre "0"

Merci
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56842 internautes nous ont dit merci ce mois-ci

Messages postés
25207
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 août 2020
5 387
Alors dans la case E25

=SI(OU(C25=0;C25="");"";1)

la forme du texte n'a pas d'importance
Respecter bien tous les signes
ça devrait fonctionner.

crdlmnt
Messages postés
25207
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 août 2020
5 387
Bonjour

pourquoi utiliser NBVAL pour une seule cellule?

=SI(OU(B25="";B25=0);"";1)
et si vous avez une bonne raison d'utliser NVAL (?)
=SI(OU(B25="";B25=0);"";NBVAL(B25))
crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
9
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013
1
Ah oui en effet, j'essaye.

Merci
Messages postés
25207
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 août 2020
5 387
.. maintenant, si c'est pour compter le nombre be valeur en B différentes de 0, vous pouvez l'avoir directement sans le renvoi dans une autre colonne avec:

=NBVAL(B:B)-NB.SI(B:B;0)
Messages postés
9
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013
1
J'ai trouve grace a vous Vaucluse

Pourquoi faire compliqué,

=SI(C26=0;"0";"1")

je ne sais pas pourquoi je me complique des fois.

Merci
Messages postés
25207
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 août 2020
5 387
Bien mais il s'agit donc de C26 alors qu'on a commencé avec B25 et bensuite C25... pourquoi faire simple? :-))
Plus sérieusement:
éviter de mettre les valeurs numériques entre guillemets sinon vous ne pourrez pas les utiliser ensuite si besoin pour des calculs successifs.(les guillemets transforme les valeurs en texte)
Bonne route
Messages postés
9
Date d'inscription
mardi 19 mars 2013
Statut
Membre
Dernière intervention
19 mars 2013
1
Ok merci pour ce conseil ... merci bcq