Comment accéder à une page jsp située dans le dossier WEB-INF [Résolu/Fermé]

Signaler
Messages postés
294
Date d'inscription
jeudi 3 janvier 2013
Statut
Membre
Dernière intervention
19 novembre 2013
-
Messages postés
294
Date d'inscription
jeudi 3 janvier 2013
Statut
Membre
Dernière intervention
19 novembre 2013
-
Bonjour,


je suis le tutoriel du site du zero sur le developpement java EE ( entreprise edition) , et à l'un des chapitres , il est demandé de mettre les pages jsp dans le dossier WEB-INF , et ensuite de configurer une servelt , afin que depuis ce dossier , on puisse avoir accès à la page jsp , à partir de l'url , j'ai bien suivi les indications ,, voilà , ce que j'ai saisi dans ma servlet :

package com.sdzee.servlets;
import java.io.IOException;
import java.io.PrintWriter;

import javax.servlet.ServletException;
import javax.servlet.http.HttpServlet;
import javax.servlet.http.HttpServletRequest;
import javax.servlet.http.HttpServletResponse;
public class Test extends HttpServlet {

	
	public void doGet( HttpServletRequest request, HttpServletResponse
			response ) throws ServletException, IOException {
			 this.getServletContext().getRequestDispatcher( "/WEB-INF/test.jsp"
			).forward( request, response );
			}
}





ensuite voici le contenu de ma page jsp située dans le dossier WEB-INF :
<! DOCTYPE html>
<html>
<head>
<meta charset="utf-8">

<title>  page JSP</title>
</head>
<body>


<p> Ceci est ma première page jsp </p>



</body>
</html>



Mais quand j'essaie d'accéder à ma page jsp à partir de l'url , , j'ai une erreur 404 : description La ressource demandée n''est pas disponible. , pourriez vous m'aider ?
j'ai beau fouillé , je n'arrive pas à déceler l'erreur , pourriez vous m'aider ?
merci de votre attention

2 réponses

Messages postés
608
Date d'inscription
mardi 12 janvier 2010
Statut
Membre
Dernière intervention
25 octobre 2015
71
bonsoir,

avez vous actualisé le fichier web.xml, qui relie la servlet avec l'adresse d'accés à la page JSP?
en plus, le dossier WEB-INF n'est pas accessible via l'adresse du local-host...
il faut bien vérifié la configuration relative de la servlet dans le fichier web.xml
Messages postés
294
Date d'inscription
jeudi 3 janvier 2013
Statut
Membre
Dernière intervention
19 novembre 2013
4
merci , au fait , j'avais oublié de spécifier l'url dans ma servlet ( url-pattern) ,
le problème a été résolu , merci