Formule en SI

Fermé
BAYOBEN Messages postés 1 Date d'inscription mercredi 27 février 2013 Statut Membre Dernière intervention 27 février 2013 - 27 févr. 2013 à 17:19
chossette9 Messages postés 4239 Date d'inscription lundi 20 avril 2009 Statut Contributeur Dernière intervention 12 septembre 2014 - 27 févr. 2013 à 17:27
Bonjour,

je cherche une formule qui que :
si la valeur de ma cellule A1 commence par 1 alors 1, que si elle commence par 2 alors 2, que si elle commence par 3 alors 3 sinon rien.

merci pour votre aide car je ne trouve pas la solution.


1 réponse

chossette9 Messages postés 4239 Date d'inscription lundi 20 avril 2009 Statut Contributeur Dernière intervention 12 septembre 2014 1 299
27 févr. 2013 à 17:27
Bonjour,

=SI(CNUM(GAUCHE(A1;1))<=3;CNUM(GAUCHE(A1;1));"")

Cette formule cherche si le 1er caractère de A1 est 1, 2 ou 3. Si c'est le cas alors on retour le 1er caractère de A1, sinon on ne retourne rien.

Cordialement.
0