Mise en forme conditionnelle: si cell non vide date autre cell

[Résolu/Fermé]
Signaler
Messages postés
4
Date d'inscription
samedi 16 février 2013
Statut
Membre
Dernière intervention
16 février 2013
-
Messages postés
4
Date d'inscription
samedi 16 février 2013
Statut
Membre
Dernière intervention
16 février 2013
-
Bonjour,

Je travaille actuellement sur un fichier excel 2010, lequel contient plusieurs colonnes avec différentes informations.

Dans la colonne S: c'est une date
La colonne U est habituellement vide mais quand j'ai du texte, je veux que dans mon colonne V que ça inscrive une date 180 jours de plus que la date indiquée dans la colonne S.

J'avais commencé à inscrire: =SI(ESTTEXTE($U4);$V4=$S4+180)

Malheureusement, ça ne fonctionne pas. Est-ce que quelqu'un peut m'aider?

Merci à l'avance.

2 réponses

Messages postés
54844
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 octobre 2021
16 758
Bonjour.

Petite erreur de syntaxe :
à la place de =SI(ESTTEXTE($U4);$V4=$S4+180)
en V4, écrire =SI(ESTTEXTE($U4);$S4+180)

Cordialement.

C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
Messages postés
4
Date d'inscription
samedi 16 février 2013
Statut
Membre
Dernière intervention
16 février 2013

Ça ne fonctionne pas ;(
Messages postés
4
Date d'inscription
samedi 16 février 2013
Statut
Membre
Dernière intervention
16 février 2013

J'ai également réessayer votre formule...désolée, j'ai été trop rapide dans ma réponse. C'est moi qui avait fait une erreur. Ça fonctionne. Un gros merci à vous aussi. C'est ma première fois sur «Comment ça marche» et je ne pensais vraiment pas obtenir de l'aide aussi rapidement.
Messages postés
24200
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
6 929
Bonjour,

en V4 :
=SI(ESTTEXTE($U4);$S4+180;"")
ou :
=SI($U4<>"";$V4=$S4+180;"")
Si U4 différent de (vide) alors...

Et si tu veux 6 mois pile-poil (même jour dans le mois) remplacer :
$S4+180
par :
mois.decaler(S4;6)

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
Messages postés
4
Date d'inscription
samedi 16 février 2013
Statut
Membre
Dernière intervention
16 février 2013

Je viens d'essayer vos 2 formules....merci! Ça fonctionne. Je vais faire quelques essais pour voir laquelle des deux formules est la plus adaptée à mon besoin. Je ne crois pas que le 6 mois jour pour jour soit essentiel.

Un gros merci.