Formule excel avec SI&ET et recopie la formule vers le bas [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013
-
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013
-
Bonjour,

Quelqu'un peut il me venir en aide SVP

J'ai une liste de factures avec date et montant et je dois les affecter dans des colonnes soit facture de moins de six mois soit facture de plus d'un ans.

Voici ce que j'ai réussi a faire
G1 = 30/06/12 J1 = 01/01/12

DATE MONTANT T.T.C + 6mois + 1an

30/11/12 91€ =SI(B4>G1;0;F4) =SI(B4<J1;F4;0)



B4 = 30/11/12 - G1 = 30/06/12 J1 = 01/01/12 F4 = Montant

Je cherche à écrire la formule qui me permettrai d'affecter le montant d'une facture dans une colonne soit la colonne facture moins de 6 mois soit facture à plus d'un an
avec la formule si j'ai écrit dans la colonne moins de six mois =SI(B4>G1;0;F4) , et dans une autre colonne facture à plus un ans j'ai écrit =SI(B4<J1;F4;0) . Il y a surement plus simple mais je n'y arrive pas. De plus pour recopier la formule vers le bas sans changer G1 ou J1 ça ne fonctionne pas et je ne peux pas mettre J$1$

Cordialement

10 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 204
Bonjour,

Si tu pouvais nous mettre un exemple sans éléments personnels mais avec la structure des données sur https://www.cjoint.com/ puis nous mettre le lien généré ici ce serait plus facile.
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013

Je voudrais bien mettre un lien mais je ne sais pas faire

Alors je vais tenter de d'expliquer

A1 = 30/06/12 B1 = 01/01/12
b1 = Date de la Facture
b2 = Montant de la facture
b4 = Facture de moins de 6 mois
b5 = Facture de plus d'un ans
B6 = Montant de la facture si la date de la facture est inférieur a A1 sinon = 0
B7 = Montant de la facture si la date de la facture est inférieur a B1 sinon = 0

En fait je voudrais que selon la date de la facture le montant apparaisse dans la colonne facture de + de 6 mois ou dans la colonne facture à plus un ans

Je vous remercie d'essayé de m'aider .
Cordialement
Messages postés
52515
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
14 387
Bonjour zs100.

1) On aurait compris beaucoup plus facilement si tu avais joint ton fichier ( en collant le lien que tu aurais créé avec https://www.cjoint.com/ )

2) Non, il n'y a pas plus simple.

3) "je ne peux pas mettre J$1$" : Pourquoi ? C'est pourtant indispensable !
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013

Bonsoir

J'ai tenté de faire ce lien je ne sais pas si cela peut fonctionner

https://www.cjoint.com/?3BpwI78dXiE
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013

je ne peux pas mettre J$1$" : Pourquoi ? C'est pourtant indispensable !

Oui c'est indispensable mais quand je mais les $ j'ai un message qui dit la formule que vous avez tapée contient une erreur, et la formule fonctionne sans les $ mais du coup je ne peux pas la recopier.

merci de votre aide
Messages postés
52515
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
14 387
Excuse-moi, zs100 : J'ai recopié J$1$ machinalement, alors qu'il s'agissait bien entendu de $J$1 !
Messages postés
52515
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
14 387
Par ailleurs, en regardant les exemples de ton fichier, je ne suis pas certain que tes formules répondent exactement aux conditions que tu as fixées, et qui changent parfois : tu avais "moins de 6 mois" au début et à la fin de ta question initiale, mais +6 mois au beau milieu !
Et on retrouve ce + 6 mois en cellule H2 de ton fichier.

Regarde ce que donne ton fichier quand on calcule les écarts en mois (colonnes G et J) :
https://www.cjoint.com/?CBpxLSHdQ0w

Cordialement.
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013

Voila ce que j'ai tapée et je peux recopier sans que la cellule change
=SI(B8<J$1;F8;0) pour cela c'est ok pas pour le reste, mais c'est un bon début

Merçi
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 204
Bonjour,

Cela te convient-il ?

https://www.cjoint.com/c/CBpxMpFBlOd
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013

Bonsoir

C'est presque cela que je souhaitai. le montant s'affiche dans la colonne créance de + de 6 mois ou dans la colonne + un ans mais pas les deux cest à dire pour une date de facture exemple du 10/11/2011 elle à effectivement plus de 6 mois au 31/12/2012 mais c'est la valeur la plus forte qui doit l'emporter donc la colonne + d'un ans et la je ne sait pas faire non plus

en tout cas merci de votre aide je n'ai plus qu'à faire un choix lorsque le montant s'affiche dans les deux colonne , c'est déja moins long.

cordialement
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 204
Bonsoir,

Alors voici la formule complète :

https://www.cjoint.com/c/CBqa1SYrihf
Messages postés
52515
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 octobre 2020
14 387
C'est une nouvelle contrainte que tu soumets : elle ne figurait dans aucun de tes messages précédents ...
En H4 il faut modifier la formule =SI(B4>$G$1;0;F4) qui devient
=SI(I4>0;0;SI(B4>$G$1;0;F4))
Messages postés
8
Date d'inscription
vendredi 15 février 2013
Statut
Membre
Dernière intervention
16 février 2013

Bonjour

Je vous remercie beaucoup de votre aide, maintenant c'est parfais

Cordialement

ZS