Calcul de moyenne de cellules contenant des formules

[Résolu/Fermé]
Signaler
Messages postés
39
Date d'inscription
jeudi 6 décembre 2012
Statut
Membre
Dernière intervention
13 juin 2016
-
Messages postés
17533
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2021
-
Bonjour,

J'ai un probleme avec le calcul de la moyenne sur mon tableau excel.

Les cellules de ce tableau contiennent toutes des formules faisant référence a d'autres tableaux.

Lorsque je fais la moyenne des cellules K6:BK6, il prend en compte l'ensemble des cellules de la plage vide et non vide.
Exemple:
SOmme de K6:BK6 = 60
les cellules renseignées sont K6=12, w6=12, X6=12, Y6=12, Z6=12
Le resultat obtenu est egale a 1,2 alors que celui devant apparaitre est de 12.

Je souhaiterai savoir comment faire la moyenne de mes cellules contenant un nombre.

Merci d'avance de votre réponse.

Cordialement

KD

5 réponses

Messages postés
17533
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2021
4 723
Salut,

Une formule génére un résultat voire égale à 0 si aucune condition n'est rempli, mais pour te proposer une formule il serait souhaitable d'avoir un exemple de ton fichier que tu peux joindre avec ce lien

https://www.cjoint.com/
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 692
Bonjour,

Comme dit Mike (bonjour), une formule génère toujours un résultat mais malheureusement, une formule du type :
=A1 (ou toute autre cellule même externe)
donne 0 lorsque la cellule est vide.
Il faut remplacer cette formule par :
=SI(ESTVIDE(A1);"";A1)
ou éventuellement par
=SI(A1<>"";A1;"")
Messages postés
39
Date d'inscription
jeudi 6 décembre 2012
Statut
Membre
Dernière intervention
13 juin 2016
2
Bonjour à tous et joyeux noel,

Ci-joint le fichier excel afin de mieux vous faire comprendre ma problématique.

L'exemple donné se situe en ligne 16.

https://www.cjoint.com/?3LAlUXykpDB

Cordialement

KD
Messages postés
17533
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2021
4 723
Re,

Pour la ligne 16, en K16 remplace ta formule usine à gaz par

=SOMME('FDG (1):FDG (31)'!AC64)
ensuite incrémente la vers la droite

En BM16 plusieurs possibilités

=SOMME(K16:BK16)/NB.SI(K16:BK16;">0")

ou tu te sers de la somme en BL16
=BL16/NB.SI(K16:BK16;">0")

en fait tu fais la somme de la ligne comme en BL16 puis tu divises cette somme par le nombre de cellule ayant une valeur >0
Re

Ok, merci bcp pour ta réponse.

Cordialement

KD
Messages postés
17533
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2021
4 723
Tu nous diras si cela te convient
Re,

Tout est ok, ça fonctionne à merveille.

Merci pour tout
Messages postés
17533
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 septembre 2021
4 723
Re,

N'oublie pas d'alléger toutes tes formules sur le principe de la ligne 16, tu gagneras en taille sur ton fichier qui est déjà pas mal chargé et en rapidité à l'ouverture comme en fonctionnement