Formule avec SI, OU, ET contenant une erreur dans les critères

Résolu/Fermé
youkette - 14 déc. 2012 à 14:53
 youkette - 14 déc. 2012 à 15:40
Bonjour,

J'ai un petit soucis avec cette formule, que je n'arrive pas à résoudre :

Voici ma formule :
=SI(OU(ET(AJ351=1;AJ351=2);ET(AU351<=24;AU351<=48));"Dans les délais";"Hors délais")

En colonne AJ j'ai des données du type : 1 ou 2 elles correspondent à des priorités.
1 = 24 maxi
2 = 48 maxi

avec ma formule tout est ok, sauf pour les priorité 2 qui me donne un résultat "Hors délais" pour 48 heures, alors que cela devrait être "dans les délais".

Je sèche.... Pouvais vous me dire ou est mon erreur. Merci ++++



3 réponses

ginto5 Messages postés 10932 Date d'inscription mercredi 4 juin 2008 Statut Membre Dernière intervention 2 février 2023 682
14 déc. 2012 à 15:01
Bonjour,

Je ne vois pas a quoi sert ce ET : SI(OU(ET
0
si je l'enlève cela ne fonctionne plus, il me dit que j'ai trop d'arguments dans la formule !! ????
0
ginto5 Messages postés 10932 Date d'inscription mercredi 4 juin 2008 Statut Membre Dernière intervention 2 février 2023 682
14 déc. 2012 à 15:22
Ben tu enlèves aussi une paire de parenthèses, mais si tes parenthèses sont bien par paire, ça ne devrait pas gueuler.
0
chossette9 Messages postés 4239 Date d'inscription lundi 20 avril 2009 Statut Contributeur Dernière intervention 12 septembre 2014 1 298
14 déc. 2012 à 15:33
Bonjour,

ce serait pas plutôt :
=SI(OU(ET(AJ351=1;AU351<=24);ET(AJ351=2;AU351<=48));"Dans les délais";"Hors délais")

Histoire de dire que tu es dans les délais pour une priorité 1 si c'est inférieur à 24h, ou pour une priorité 2 si c'est inférieur à 48h.

Cordialement.
0
c'est exactement cela ! et ça fonctionne .. super merci++++++

un oeil neuf c'est toujours mieux

cordialement
0