[Symfony] Intégrer les feuilles de style dans une vue twig

Résolu/Fermé
Mardoch Messages postés 12 Date d'inscription mercredi 10 octobre 2012 Statut Membre Dernière intervention 2 novembre 2012 - 29 oct. 2012 à 13:44
 GAMC - 1 juin 2013 à 13:00
Bonjour à tous,
j'ai un autre problème et je m'excuse de poser trop de questions
En fait je veux utiliser le bootstrap de twitter comme feuille de style pour designer l'affichage de mes vues mais malheureusement, ça ne marche pas! aucune mise en forme ne s'effectue.
j'ai mis le bootstrap.css dans le dossier F:\wamp\www\Symfony\src\Election\SecretBundle\Resources\public\css
et puis j'ai publié ça dans mon dossier web à l'aide de la commande
php app/console assets:install web
désormais j'ai F:\wamp\www\Symfony\web\bundles\electionsecret\css\bootstrap.css et
F:\wamp\www\Symfony\src\Election\SecretBundle\Resources\public\css\bootstrap.css . Ensuite, dans mon layout de base (principal) j'ai intégré le css de la sorte (ligne 7)

<!DOCTYPE html>
<html>
    <head>
        <meta charset="UTF-8" />
        <title>{% block title %}Gestion des élections{% endblock %}</title>
        {% block stylesheets %}
            <link rel="stylesheet" href="{{ asset('css/bootstrap.css') }}" type="text/css"/>
        {% endblock %}
    </head>


J'appelle le layout principal dans le layout fils et les informations s'affiche bien mais il n'y a pas de style, pas de mise en forme. Rien n'est beau
Alors aidez-moi s'il vous plaît...Est-ce que je l'ai bien intégré ou pas?

2 réponses

Mardoch Messages postés 12 Date d'inscription mercredi 10 octobre 2012 Statut Membre Dernière intervention 2 novembre 2012
2 nov. 2012 à 12:00
C'est le chemin qui n'était pas bon; il fallait le référencer à partir du dossier WEB
Merci à tous
0
Bjr,
J'ai le même problème comment t'as fait.
Je ne comprends pas comment tu l'as corrigé
Merci d'avance
0