Heure sur kubuntu

Résolu/Fermé
françoise - 24 sept. 2012 à 20:32
mamiemando Messages postés 31505 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 octobre 2022 - 22 oct. 2012 à 21:41
Bonjour,
j'ai un souci depuis toujours en fait... je n'arrive pas à synchroniser l'heure sur mon pc? Je m'explique : j'accède parfaitement pour régler date et heure, la date est ok, la pendule est bien réglée mais l'icône sur le bureau affiche 2h de retard! j'ai pourtant le fuseau horaire correct, j'ai réglé à la fois sur "serveur de temps public" ou "europe.pool...", aucun changement...
Que se passe t-il? pouvez-vous m'aider?
merci beaucoup!



9 réponses

mamiemando Messages postés 31505 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 octobre 2022 7 427
Modifié par mamiemando le 24/09/2012 à 23:22
Normalement si tu as installé le paquet ntp tu dois pouvoir faire en sorte que l'heure se règle automatiquement.

Essaye aussi de régler l'heure avec la commande hwclock et date. Puis une fois l'heure réglée, si le fichier /etc/adjtime existe, supprime-le. En root :

En admettant qu'il soit 23:18 à l'heure UTC :

hwclock --set --date="2012-09-24 23:18:00" 
date --utc 09242318
rm /etc/adjtime


Bonne chance
0
Bonsoir mamiemando,
j'ai installé ntp, puis réglé l'heure avec hwclock --set --date="2012-09-25 21:19:00"
hwclock: Sorry, only the superuser can change the Hardware Clock.
puis en root, mais rien n'a changé...pourtant : date m'affiche
mardi 25 septembre 2012, 21:19:48 (UTC+0200) je ne comprends pas...
merci mamie pour tes précisions;)
0
Anthony63 Messages postés 2733 Date d'inscription vendredi 30 avril 2010 Statut Membre Dernière intervention 12 janvier 2020 1 187
25 sept. 2012 à 21:46
En démarrant ton pc tu tapes la touche F qui correspond au bios et tu pourra régler l'heure Et ensuite enter et relancer ton OS Linux ou Windows.
0
BMMWW Messages postés 1487 Date d'inscription mercredi 8 août 2012 Statut Membre Dernière intervention 18 mai 2019 252
25 sept. 2012 à 21:46
As-tu été voir dans le Bios, c'est normalement sur cette heure que se base le PC.
Pour aller dans le Bios, il faut presser la touche (ou les touches) indiquée dans le bas de l'écran au démarrage. Attention c'est très rapide !...
Quand tu es dans le Bios, c'est normalement sur la page "Main" et sous la rubrique "System time"...
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
je ne passe pas dans le bios avec F? je n'ai pas windows...
aussi, faut-il vraiment aller dans le bios??
juste pour info ça ne va pas mieux, je ne trouve pas :
hwclock --show
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.
hwclock --debug
hwclock de util-linux 2.20.1
hwclock: Ouverture de /dev/rtc a échoué: Permission non accordée
Aucune interface d'horloge utilisable n'a été repérée.
hwclock: Cannot access the Hardware Clock via any known method.
hwclock --debug
[sudo] password for francoise:
hwclock de util-linux 2.20.1
Utilisant /dev interface to clock.
Le dernier ajustement de dérive a été fait 1348601400 secondes après 1969
La dernière calibration a été faite 1348601400 secondes après 1969
L'horloge matérielle fonctionne selon le temps UTC
On assume que l'horloge matérielle est conservée dans le temps de UTC.
En attente d'un tic d'horloge...
... a obtenu un tic d'horloge
Heure lue de l'horloge matérielle : 2012/09/25 20:20:12
Heure de l'horloge matérielle : 2012/09/25 20:20:12 = 1348604412 secondes depuis 1969
mar. 25 sept. 2012 22:20:12 CEST -0.543461 secondes
merci
0
mamiemando Messages postés 31505 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 octobre 2022 7 427
26 sept. 2012 à 08:35
Comme le message d'erreur l'indique, la commande hwclock requiert des droits root. Donc passe en root ou utilise sudo.

Bonne chance
0
bonjour mamiemando,
oui, je l'avais bien fait, plus haut, je ne t'ai peut -être pas tout détaillé : hwclock --debug
[sudo] password for francoise:
hwclock de util-linux 2.20.1
Utilisant /dev interface to clock. etc...
rien n'y fait malheureusement au final... merci beaucoup de ton aide
0
mamiemando Messages postés 31505 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 octobre 2022 7 427
26 sept. 2012 à 21:26
Mmmh je ne sais pas mais au pire utilise un fuseau horaire décalé de 2h pour corriger le problème. Est-ce que tu as l'heure et le fuseau horaire corrects en tapant la commande "date" ?
0
Bonsoir mamiemando,
oui mamiemando, actuellement l'heure et date sont correctes :
mercredi 26 septembre 21:42:43 (UTC+0200)
pas grave, il faudrait donc changer le fuseau horaire, je testerai, merci beaucoup!
à bientôt
0
Bonjour,
je vous informe que le problème vient de se résoudre simplement grâce à une mise à jour ce week end
comme quoi parfois...merci en tous cas!
0
mamiemando Messages postés 31505 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 octobre 2022 7 427
22 oct. 2012 à 20:42
Petite précision, tu peux installer le paquet ntp qui corrige automatiquement l'heure. KDE est prévu au niveau de l'interface pour interagir directement avec ntp.
0
oui mamiemando, (dans mon 3ème message), j'avais installé ntp mais sans résultat...
là je crois que ça devait être un bug qui a été rectifié par une mise à jour parce que je n'ai pas touché depuis;)
merci d'avoir indiqué "résolu" et pour ton grand investissement, comme toujours;)
bonne soirée
0
mamiemando Messages postés 31505 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 octobre 2022 7 427
22 oct. 2012 à 21:41
Je t'en prie, à bientôt ;-)
0