[Excel] Formules donnent resultat faux

Fermé
Fyah_Fy Messages postés 704 Date d'inscription mercredi 30 août 2006 Statut Membre Dernière intervention 17 novembre 2022 - 23 août 2012 à 09:28
Patrice33740 Messages postés 8553 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 24 octobre 2022 - 24 août 2014 à 16:25
Bonjour,

J'ai une fiche model faite sur Excel 2003 avec un onglet base de donnée et un onglet avec des formules de fou (genre 5-6 lignes)

Je viens de me rendre compte qu'en ouvrant le même fichier sur un Excel 2007 et Excel 2010 les résultats des formules sont différents. En recalculant à la main hier, il semblait que le 2007 etait juste alors que le 2010 était faux.

Ce matin j'ai pris une autre fiche et il semble que le 2010 soit juste et le 2007 faux.

Je suis perdu.
Qu'en pensez vous?





5 réponses

Patrice33740 Messages postés 8553 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 24 octobre 2022 1 758
23 août 2012 à 10:13
Bonjour,

Même avec des formules de fou, Excel ne se trompe qu'exceptionnellement !!!

Il est bien plus probable que le contexte ne soit pas rigoureusement identique ou que les formules ne soient pas parfaitement adaptées.
2
Fyah_Fy Messages postés 704 Date d'inscription mercredi 30 août 2006 Statut Membre Dernière intervention 17 novembre 2022 68
23 août 2012 à 10:21
Quand je dis "formules de fou" c'est pour expliqué que c'est pas facile à comprendre maintenant qu'elle ont été faite.

Il se trouve que le même fichier (sur serveur), ouvert en lecture seul sur les 2 ordinateurs donne des résultats differents
0
Patrice33740 Messages postés 8553 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 24 octobre 2022 1 758
23 août 2012 à 10:33
C'est pas forcement anormal, pourquoi est-il en lecture seule ?!
0
Fyah_Fy Messages postés 704 Date d'inscription mercredi 30 août 2006 Statut Membre Dernière intervention 17 novembre 2022 68
23 août 2012 à 10:34
il est en lecture seul sur le second pc, pardon.
0
Patrice33740 Messages postés 8553 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 24 octobre 2022 1 758
23 août 2012 à 11:03
Quelle est la formule en cause ?
0
Fyah_Fy Messages postés 704 Date d'inscription mercredi 30 août 2006 Statut Membre Dernière intervention 17 novembre 2022 68
23 août 2012 à 11:18
=SI(OU(AI6="-";ESTERREUR(MOYENNE(DECALER(Date_debut_exploit;($AI6-Date_debut_exploit)/pas_exploit;1):DECALER(Date_debut_exploit;(($AI6-Date_debut_exploit)/pas_exploit)+(1/pas_exploit)-1;1))*24));"-";MOYENNE(DECALER(Date_debut_exploit;($AI6-Date_debut_exploit)/pas_exploit;1):DECALER(Date_debut_exploit;(($AI6-Date_debut_exploit)/pas_exploit)+(1/pas_exploit)-1;1))*24)
0