Excel -> =NB.SI.ENS(A1:A2;"Faux [Résolu/Fermé]

Signaler
Messages postés
509
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
-
Messages postés
509
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
-
Bonjour,

quelqu'un pourrait-il m'expliquer pourquoi quand je mets
=NB.SI.ENS(A1:A2;"Faux")

Il me cherche des boolean FAUX ?
pourtant il y a des guillements !


Merci d'avance,


Version : Excel 2007

3 réponses

Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
46
Bonjour,

pourrais-tu être un peut plus explicite ?
"Faux" est ton critère ?
Messages postés
23990
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
6 719
Bonjour,

Quand excel peut convertir une chaine en numérique il le fait.
Faux est donc converti, un booléen étant un numérique.

eric

edit: tu peux t'en tirer avec :
=NB.SI.ENS(A1:A10;TEXTE("Faux";"texte"))
qui comptera les vrai FAUX qui sont des textes (tu suis ? ;-) )

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
Messages postés
509
Date d'inscription
lundi 9 mai 2011
Statut
Membre
Dernière intervention
17 avril 2013
94
ah ! ça devait fonctionner !, pas frocément logique le systeme mais bon, on va s'y faire ^^

Merci :)