Configuration apache2 sous debian

Résolu
Bonjour,

mon problème dans la configuration de apache2
je crée ds
# nano /etc/apache2/sites-available/test1.com
<VirtualHost *>
ServerAdmin postmaster@machine1.com
ServerName www.machine1.com
ServerAlias test1.com *.machine1.com
DocumentRoot /home/machine1/public_html/
<Directory /home/machine1/public_html/>
Options -Indexes FollowSymLinks MultiViews
AllowOverride All
</Directory>
ErrorLog /home/machine1/logs/error.log
ce fait ça
mais ds le journal # nano /etc/apache2/apache2.conf
je trouve pas ou je dois modifier pour redirection

DirectoryIndex index.html index.php index.xhtml

car lorsque je fais # /etc/init.d/apache2 restart
il me marque comme message <gras> Error log may have more Information
</gras>
merci d'avance

5 réponses

  1. Modérateur
    Il y a sans doute une erreur de syntaxe dans ton fichier de configuration, ou celui ci fait référence à des répertoires incorrects (par exemple qui n'existent pas).

    Normalement, si des erreurs sont dans le fichier, apache va écrire ces erreurs dans un fichier de log (dont le nom varie selon la distribution), typiquement /var/log/apache2/error.log sous debian. Lance par exemple dans un terminal la commande :

    tail -f /var/log/apache2/*log


    Passe quelques lignes en appuyant sur entrée.
    Puis dans un autre terminal lance :

    service apache2 restart


    Les lignes qui sont apparues devraient alors t'aider à déterminer la cause du problème.

    Bonne chance
    0
    1. merci ,
      oui je corrigé depuis toute a l heur je plus cette faute et apres
      dans /etc/apache2/apache.conf
      je modifier et la le message :
      [Error] (eai 2) name or service not Know could not resolve host name adresse_IP -- Ignoried .
      [ date] name VirtualHost *:80 has no VirtualHosts
      [ date] name VirtualHost *:80 has no VirtualHosts
      0
      1. Modérateur
        Je t'invite à suivre ce tutoriel, dans lequel l'erreur que tu viens de soulever est également traitée.
        http://www.mistra.fr/tutoriel-linux-serveur-web-apache2.html

        Bonne chance
        0
        1. merci
          bonne journée
          0
          1. Modérateur
            De rien bonne journée également !
            0