Repérer les lignes qui sont des doublons

Résolu/Fermé
philub Messages postés 254 Date d'inscription samedi 31 mars 2007 Statut Membre Dernière intervention 28 mars 2015 - 22 juin 2012 à 05:22
PHILOU10120 Messages postés 6174 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 4 décembre 2022 - 22 juin 2012 à 11:14
Bonjour,

Voici mon problème:

1) Environ 6000 lignes d'entrés de données sur 3 colonnes dans Excel 2003.

2) J'ai essayé, sur Excel d'éliminer les lignes qui sont des doublons. Je les ai juste masqué avec un filtre élaboré, alors que je dois les supprimer définitivement.

3) J'ai fait une mise en forme conditionnelle pour mettre certaines données en surbrillance, mais ça demande beaucoup de manipulations manuelles et j'ai peur de faire une erreur.

4) J'ai essayé des Macro trouvées sur le Net, mais j'ai des problèmes de syntaxe et je suis nul.

5) J'ai mit mon fichier Excel dans Access pour pouvoir y faire plus de manipulations, mais je suis un débutant sur Access.

Mes données ressemble un peu à ça:

À l'origine

UI200 99 Z1
UI200 98 Z2
UI200 99 Z3
UI201 99 Z1
UI200 99 Z2
UI200 98 Z2
UI201 99 Z1

Ce que je souhaite

UI200 99 Z1; Z2;Z3
UI200 98 Z2

En solutionnant cette question, vous deviendrez un demi-dieu.


1 réponse

PHILOU10120 Messages postés 6174 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 4 décembre 2022 745
22 juin 2012 à 11:14
Bonjour

Ma méthode elle n'est certainement pas la meilleur mais on y arrive

1°- trier la liste par ordre croissant
2°- chercher les doublons avec cette formule '=SI(NB.SI($A1:$A$200;$A1)>1;1;0)
3°- filtrer la liste sur la colonne doublon critére 1 et supprimer toutes les lignes
4°- mettre cette formule sur la deuxiémé ligne de la liste et la tirer sur toute la hauteur de celle-ci

'=SI(GAUCHE(A2;NBCAR(A2)-2)=GAUCHE(A1;NBCAR(A1)-2);B1&"; "&DROITE(A2;2);A2)
copier la cellule a1 en B1

en considérant qu'il n'y a que 2 caractéres à récupérer (Z1)
1