Problème MySQL ne fonctionne plus

Résolu
Bonjour,
Je suis sur un serveur de production donc je ne peux pas le redémarrer. J'avais un problème récurrent avec MySQL mais après quelques recherches, il s'est avéré que c'était un manque de place sur le disque.
Maintenant j'éssaye de redémarrer le service de MySQL avec service mysqd restart mais je n'y arrive pas, il y a un timeout.
Et quand j'essaye d'accéder à mysql via le terminal j'ai l'erreur:

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111)


J'ai essayé plusieurs solutions, le fichier en question est bel et bien existant, mais rien a faire ça ne fonctionne pas.

Quelqu'un aurait-il une solution?

2 réponses

  1. salut,

    tu peux nous donner les log (/var/log/mysql.log et /var/log/mysql.err)
    0
    1. Il s'est avéré que le mysql ne pouvait accéder au fichier en question (manque de droit) donc un chmod à réglé le problème.
      0