Iphoto affiche un point d'exclamation ! [Fermé]

Signaler
Messages postés
2
Date d'inscription
dimanche 20 février 2011
Statut
Membre
Dernière intervention
21 février 2011
-
Messages postés
37688
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
31 août 2020
-
Bonjour,

Je rencontre un souci d'affichage de photo dans iPhoto 11 (version 9.2.3) récemment mis à jour par Apple.

en effet, de façon aléatoire, lorsque je parcours les événements de mes photos, je vois bien les imagettes, mais lorsque je clique pour éditer une image grandeur "nature", un point d'exclamation s'affiche en lieu et place de la photo.

Cette icône est visible ici : http://mikeyogaparis.com/Personnel/iphoto/Bug_iphoto.jpg

Je constate que les images réelles sont bien présentes puisque je peux les éditer avec l'aperçu du Mac en les cherchant manuellement.

Je constate aussi qu'il semble que ce souci apparaisse de façon aléatoire.

Enfin, je pense que cela s'est produit seulement depuis la dernière mise à jour de Iphoto.

enfin (bis), parfois les images apparaissent, parfois non, parfois aucune (ou très peu) s'affichent.

J'ai réparé les autorisations comme de coutume et le Mac est parfaitement à jour. Je passe les scripts Onyx chaque semaine et CCleaner a nettoyé le Mac cette semaine, donc à priori pas de souci d côté de la santé du Mac ... (par ailleurs tous mes autres logiciels fonctionnent parfaitement).

Je pensais au début un souci d'affichage à cause de la taille (des images 2000 sur 3000 pixels), ou de l'appareil source (Iphone, Nikon ....) mais en fait non, le souci touche tout.

Si vous avez une idée ?

Je pensais à réparer la bibliothèque mais je n'ai jamais fait la manip, et au préalable il est conseillé de sauvegarder la bibliothèque (là aussi je n'ai jamais fait et il me propose de le faire que par Time Machine que que n'utilise pas).

Je voulais votre expertise et vos avis avant de me lancer dans les opérations. En attendant, je peux toujours importer des images dedans, mais sans assurance de pouvoir les voir soit sur le coup, soit quelques jours plus tard ....



5 réponses

Messages postés
37688
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
31 août 2020
9 940
Bonjour,

Je constate que les images réelles sont bien présentes puisque je peux les éditer avec l'aperçu du Mac en les cherchant manuellement.


C'est peut-être là le problème. Il ne faut jamais faire d'intervention "manuelle" dans la photothèque d'iPhoto. Seul iPhoto est habilité à intervenir dans sa photothèque, sinon il ne retrouve plus ses petits. Le point d'exclamation indique qu'il ne retrouve pas son original.

Voyez cette page :
http://support.apple.com/kb/HT1261?viewlocale=fr_FR&locale=fr_FR

Voyez également cette discussion :
https://forums.commentcamarche.net/forum/affich-25284254-iphoto-probleme#1

Bonne chance

3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61358 internautes nous ont dit merci ce mois-ci

Messages postés
37688
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
31 août 2020
9 940
Bonsoir,

Le fait que seuls 2 événements sont concerné pourrait s'expliquer, peut-être, par le fait que ce sont les 2 seuls dans lesquels vous êtes intervenu manuellement...

Quand à la différence de traitement entre les images verticales et horizontales .. là je ne vois pas, à moins que vous ayez tourner ces images manuellement hors iPhoto ?

autrement je ne vois pas :(
Messages postés
37688
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
31 août 2020
9 940
Par intervention manuelle, je veux dire que sans passer par iPhoto, vous affichez le contenu du fichier iPhoto Library, et qu'à l'intérieur de ce "paquet-fichier", vous naviguez au travers des dossiers et manipulez des photos.

Vous indiquez que la bibliothèque a été réparée plutôt rapidement, et vous dites avoir coché toutes les bonnes options. Mais avez vous cochez carrément toutes les options. même celles que vous n'estimiez pas nécessaires ?
Messages postés
2
Date d'inscription
dimanche 20 février 2011
Statut
Membre
Dernière intervention
21 février 2011

Ben justement, ce n'est pas le cas dans les deux cas ...

- Ni fait d'intervention manuelle dedans ;
- Ni tourné les photos ailleurs ....

Et cela concerne des photos faites aussi bien par un Nokia (bien reconnu par IPhoto) que l'Iphone.

D'ailleurs par intervention manuelle vous pensez à quoi ?

A noter que j'ai rencontré ce souci seulement depuis la mise à jour de IPhoto .... Auparavant aucun problème... Je ne sais pas si ça peut avoir un rapport mais il y a des coïncidences parfois qui m'interpellent.
Messages postés
2
Date d'inscription
dimanche 20 février 2011
Statut
Membre
Dernière intervention
21 février 2011

Bonsoir amis Mac !

Alors j'ai tenté (après une sauvegarde car pas fou) la réparation de la bibliothèque et ça n'a rien donné. D'ailleurs je reste un peu sur la réserve au vu du temps très rapide qu'il a pris pour traiter les 19 Go de la bibliothèque ... En tous cas j'ai coché toutes les bonnes options ...

Je viens de constater deux choses importantes qui peuvent aider :
- seuls les photos contenues dans deux événements sont concernés, pas les autres ;
- seules les images HORIZONTALES ne passent plus, et non les verticales !