Remplacer #div0 par le chiffre 0

Fermé
Isa - 22 mai 2012 à 11:11
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 8 mai 2024 - 22 mai 2012 à 12:06
Bonjour,

Je cherche à remplacer #div0 qui est la résultat d'un calcul ou les zones sont vides par le chiffre 0
Merci

2 réponses

blux Messages postés 26039 Date d'inscription dimanche 26 août 2001 Statut Modérateur Dernière intervention 15 mai 2024 3 289
Modifié par blux le 22/05/2012 à 11:21
Salut,

Il y a toute une série de fonctions "EST" dans EXCEL qui permettent de vérifier tout un tas de propriétes (pair, impair, numérique, texte, erreur...)

Supposons que tu fais (en C1) la division de A1 par B1 et que B1 est égal à zéro ou ne contient rien.

Tu peux utiliser la fonction ESTERREUR avec un test pour afficher 0 si l'opération ne peut se faire ou afficher le résultat si l'opération est faisable.

Tu mets cette formule en C1 :

=SI(ESTERREUR(A1/B1);"0";A1/B1)
Ca devrait aller mieux...

A+ blux
 "Les cons, ça ose tout.       
C'est même à ça qu'on les reconnait"
1
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 8 mai 2024 7 216
22 mai 2012 à 12:06
Bonjour,

et
=SI(ESTERREUR(A1/B1);0;A1/B1)
sans les " " est encore mieux ;-)

eric
0