Php 5.3 migration vers serveur

[Résolu/Fermé]
Signaler
Messages postés
13780
Date d'inscription
vendredi 6 novembre 2009
Statut
Contributeur
Dernière intervention
2 novembre 2020
-
Messages postés
13780
Date d'inscription
vendredi 6 novembre 2009
Statut
Contributeur
Dernière intervention
2 novembre 2020
-
Bonjour,
ca fait deux fois que je migre mon site local vers les sites distant et j'ai encore le meme message d'érreur .

je précise qu'en local je n'ai pas d'erreur. ca peut pas avoir de rapport avec mysql qui serait mal identifier!

Pouvez vous me dire a quoi cela correspond.
Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/lionhell/public_html/index.php:1) in /home/lionhell/public_html/inc1.php on line 3

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/lionhell/public_html/index.php:1) in /home/lionhell/public_html/inc1.php on line 3


index.php:
<?php
include("inc1.php");
?>

inc1.php
<?php
// verifie si une session est en cour et permettre de traiter les liens pour les identifier et les visiteurs.
session_start();
if(isset($_SESSION['membre']))
$identification = $_SESSION['membre'];
else
$non_identifier = 'visiteur';
?>


Merci d'avance....

1 réponse

Messages postés
13780
Date d'inscription
vendredi 6 novembre 2009
Statut
Contributeur
Dernière intervention
2 novembre 2020
1 423
au départ je pensé que avant session_start(); devait y avoir aucun caractère comme j'ai lu un peu partout.
serait il possible que le include créer se problème et qu'il fesait comme si il y avait un caractère.

j ai essayer de l'enlever sur l'index et de faire le session_start() direct sans include.
cela marche mais cela m'embête bien de ne pas pouvoir inclure celui-ci!

Mais je fait pareil pour mes autres pages.
et cela me refais la même erreur alors que j'ai retirer le include.
comme si la première page ouvrez la session et que la seconde paf existe déja. Mais pourtant j'en ais besoin pour afficher si c'est un visiteur ou un membre...

je suis perdu sur easy php et xamp j ai aucun problème et je me suis toujours servie du local...

ca se passe ici!:
http://www.mars-radio-dnb.com

merci de votre aide que vous pourriez m'apporter...
Messages postés
13780
Date d'inscription
vendredi 6 novembre 2009
Statut
Contributeur
Dernière intervention
2 novembre 2020
1 423
Ca y est ca avance bon:
si je vire le include et que je fait les start session sans espace caractère rien, cela marche.
Je voudrais juste savoir si on peut pas le faire avec un include... On est obliger de le préciser a chaques pages?