Texte et calcul dans résultat formule Excel

[Résolu/Fermé]
Signaler
-
Messages postés
2
Date d'inscription
jeudi 26 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012
-
Bonjour,

Je suis un peu embêté, j'ai une formule à faire qui tient compte de plusieurs données.
J'aimerais, par le biais d'une fonction si, faire apparaitre une certaine phrase qui contiendrais un calcul avec les susdites données.

Exemple : Colonne A et Colonne B. Si ( la valeur de la colonne A > valeur de la colonne B;"Il faut acheter (valeur de la colonne A - Valeur de la colonne B ) voitures";"Ne rien faire" )

Que faut-il faire pour que le calcul se fasse automatiquement ? J'ai tenté plusieurs écritures mais à chaque fois il me marque le texte et la formule brute.

Merci d'avance


<config>Mac OS X / Safari 534.52.7</config>

2 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 291
Bonjour,

utilisez la fonction CONCATENER ou les & . Exemple :
=SI(A1>B1;"Il faut acheter " & A1-B1 & " voitures";"Ne rien faire")
ou
=SI(A1>B1;CONCATENER("Il faut acheter ";A1-B1;" voitures");"Ne rien faire")
Cordialement.
C'est exactement ça !

Merci beaucoup !
Messages postés
2
Date d'inscription
jeudi 26 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012

utiliser la fonction concatener? p)ar exemple =SI(A1>$B$1;achetervoitures;rienfaire)