EXCEL ignorer un nombre dans une formule [Résolu/Fermé]

Signaler
-
Messages postés
1109
Date d'inscription
lundi 9 novembre 2009
Statut
Membre
Dernière intervention
1 mars 2013
-
Bonjour,

J'ai un tableau ou figure un colonne de formule en pourcentage.
Dans certaines ligne j'ais des cases qui affichent 100% car il me manque une donnée dans un colonne précédente.

Je voudrais faire une formule qui me calcule la moyenne de tout ces pourcentage en ignorant les cellules qui sont égales à 100%

Merci d'avance

5 réponses

Messages postés
12594
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 185
Si tu as windows 7, tu as probablement la dernière version d''excel, et tu peux donc utiliser la fonction.... MOYENNE.SI (incroyable, non ?)

En supposant que tes valeurs à moyenner soient dans la colonne B, tu écris
=MOYENNE.SI(B:B;B:B;"<1")


Plus d'infos sur la fonction ici.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 91581 internautes nous ont dit merci ce mois-ci

Messages postés
1109
Date d'inscription
lundi 9 novembre 2009
Statut
Membre
Dernière intervention
1 mars 2013
176
Pour les personnes n'ayant pas la derniere version d'excel,
Voici une formule de Bruce Willix dans un autre post...

Pour faire simple il suffit:
1. d'additionner les cellules de moins de 100%
2. de diviser ce nombre par le nombre d'occurences pour lesquels ce critère est rencontré.

Et donc, naturellement la formule est:

=SUMIF(A1:A10;"<100";A1:A10)/COUNTIF(A1:A10;"<100")

Et en français:

=SOMME.SI(A1:A10;"<100";A1:A10)/NB.SI(A1:A10;"<100")

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 91581 internautes nous ont dit merci ce mois-ci

Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
207
Bonjour,

Plage C1:C6 à adapter à votre tableau

=SOMME.SI(C1:C6;"<>1";C1:C6)/NB.SI(C1:C6;"<>1")
Messages postés
1951
Date d'inscription
jeudi 1 décembre 2011
Statut
Membre
Dernière intervention
16 février 2012
571
Fait :
=MOYENNE.SI(A1:A3;"<100")

;)

" Votre temps est limité, ne le gâchez pas en menant une existence qui n'est pas la vôtre. " S.Jobs
Merci beaucoup à tous pour vos réponses,

La formule la plus adaptée à ma recherche est celle de bruce willix^^

Merci!!