[Debian]problème de connexion avec p3scan

Fermé
jesus144 Messages postés 35 Date d'inscription vendredi 2 avril 2004 Statut Membre Dernière intervention 31 janvier 2008 - 19 sept. 2006 à 12:56
 joebar - 8 nov. 2006 à 17:27
Bonjour,
j'essaye de mettre en place une passerelle (192.168.0.251) et un proxy pop3 avec p3scan. Pour cela j'ai p3scan en écoute sur le port 8110 de la machine et une règle iptables défini comme suis:
iptables -t nat -A PREROUTING -i eth0 -d ! 192.168.0.0/24 -p tcp --dport 110 -j REDIRECT --to-ports 8110
de façon a rediriger le traffic arrivant sur la passerelle sur le port 110 vers le port 8110.

lorsque je telnet depuis un post de travail le pop.free.fr sur le port 110, je retrouve dans mes logs
Sep 19 12:28:05 Passerelle p3scan[1337]: Selected scannertype: basic (Basic file invocation scanner)
Sep 19 12:28:05 Passerelle p3scan[1337]: Listen now on 0.0.0.0:8110
Sep 19 12:33:35 Passerelle  p3scan[1349]: Connection from 192.168.0.24:51285
Sep 19 12:33:35 Passerelle p3scan[1349]: Real-server adress is 192.168.0.254:110
ce qui parait plutot pas mal, vu que ma freebox a l'adresse 192.168.0.254. parcontre les connexions depuis outlook, ne sont pas loggées et n'aboutisses pas coté post de travail.

de même depuis un post client linux, en utilisant tcptraceroute, j'obtient:
debian:~# tcptraceroute pop.free.fr 110
Selected device eth0, address 192.168.0.24, port 51286 for outgoing packets
Tracing the path to pop.free.fr (212.27.48.3) on TCP port 110 (pop3), 30 hops max
 1  pop.free.fr (212.27.48.3) [open]  1.310 ms  1.195 ms  1.363 ms
debian:~# tcptraceroute www.free.fr 80
Selected device eth0, address 192.168.0.24, port 51287 for outgoing packets
Tracing the path to www.free.fr (212.27.48.10) on TCP port 80 (www), 30 hops max
 1  192.168.0.251  1.335 ms  1.263 ms  1.143 ms
 2  192.168.0.254  1.510 ms  1.407 ms  1.658 ms
 3  82.228.216.254  29.283 ms  29.100 ms
    vlq-6k-2-a5.routers.proxad.net (213.228.4.254)  29.363 ms
 4  * vlq-6k-2-a5.routers.proxad.net (213.228.4.254) 29.343 ms *
 5  bzn-6k-1-po5.intf.routers.proxad.net (212.27.56.201)  30.269 ms * *
 6  bzn-6k-sys-po1.intf.routers.proxad.net (212.27.57.117)  30.058 ms  33.901 ms  29.517 ms
 7  www.free.fr (212.27.48.10) [open]  30.119 ms  31.373 ms  30.279 ms
ce qui me parait cohérent avec le role de proxy de p3scan

bref, j'ai pas l'impression que ce soit tres loin, sauf que pas de mail ;-)
Est ce que ma règle iptables est correct? comment vérifier qu'elle fonctionne bien? d'ou peux venir le problème???

Merci de voter aide!

3 réponses

jesus144 Messages postés 35 Date d'inscription vendredi 2 avril 2004 Statut Membre Dernière intervention 31 janvier 2008 8
19 sept. 2006 à 12:59
ah! pardon, j'ai bien des logs de mon OutLook sur la passerelle:
Sep 19 12:36:36 Passerelle p3scan[1353]: Connection from 192.168.0.56:3736
Sep 19 12:36:36 Passerelle p3scan[1353]: Real-server adress is 192.168.0.254:110
Sep 19 12:36:44 Passerelle  p3scan[1349]: Cannot connect to real-server
Sep 19 12:36:44 Passerelle  p3scan[1349]: Session done (Critial abort). Mails: 0 Bytes: 0
Sep 19 12:39:45 Serveur_Fichiers p3scan[1353]: Cannot connect to real-server
Sep 19 12:39:45 Passerelle p3scan[1353]: Session done (Critial abort). Mails: 0 Bytes: 0


c'est pas très éxplicite... je relance p3scan en mode debug...
jesus144 Messages postés 35 Date d'inscription vendredi 2 avril 2004 Statut Membre Dernière intervention 31 janvier 2008 8
19 sept. 2006 à 13:09
bon ben le mode debug, ça aide pas beaucoup:
p3scan[1365]: Connection from 192.168.0.24:51288
p3scan[1365]: Real-server adress is 192.168.0.254:110
p3scan[1365]: Cannot connect to real-server
p3scan[1365]: Session done (Critial abort). Mails: 0 Bytes: 0
p3scan[1365]: do_sigterm_proxy, signal -1
p3scan[1365]: Uninit context
p3scan[1365]: context_uninit done, exiting now
p3scan[1364]: waitpid: child 1365 died with status 0, numprocs is now 0
p3scan[1364]: Erasing /var/spool/p3scan/children/1365/ contents
p3scan[1364]: Removing directory /var/spool/p3scan/children/1365/
Salut,

J'ai exactement le même problème avec une Debian utilisant le noyau 2.6.17.6.
Quelqu'un a-t-il une solution ?

Merci

Joe.