NB.SI sur des cellules non contiguës [Fermé]

Signaler
Messages postés
5
Date d'inscription
mardi 22 novembre 2011
Statut
Membre
Dernière intervention
22 novembre 2011
-
 Estelle -
Bonjour,
je dois effectuer le comptage des cellules contenant un critère sur de cellules qui ne sont pas contiguës, donc pas en plage du style A1:A20 mais A1;A3;A7;
Quand je construit ma formule NB.SI(A1;A3;A7;"critère") Excel me dit que trop d'arguments ont été entrés. Comment devrais-je m'y prendre?

Le fichier en question est une gestion du temps de présence quotidienne.
En verticale la liste des personnes.
En horizontale: les jours du mois avec 3 colonnes pour chaque jour. heure d'arrivée, heure de départ,total présence (avec formule).
Je dois faire une statistique des présences (par personne) suivant 3 critères: <3h, entre 3h et 5h, >5h.

Ce ne sont pas les critères qui m'ennuient mais cette histoire d'excédent d'attributs dans la plage d'analyse. D'avance je vous remercie et vous souhaite ... bonne journée, après midi ou bonne nuit
A voir également:

1 réponse

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 300
Bonjour,

la formule du NB.SI s'utilise ainsi :
=NB.SI(plage;critère).

Si vous voulez utilisez plusieurs plages, vous devrez passer par :
=NB.SI.ENS(plage_critères1;critères1;[plage_critères2;critères2];...)

Cordialement.
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 300
En fait, les crochets signifie que la plage de critère n°2 est facultative. J'aurais du le préciser.
Essaie de nouveau en enlevant les crochets.
Messages postés
5
Date d'inscription
mardi 22 novembre 2011
Statut
Membre
Dernière intervention
22 novembre 2011

maintenant j'ai un résultat mais pas le bon. il m'affiche "1" même si le contenu des 2 cellules est >3.
Je précise que le format de ces 2 cellules (E6 et H6) est formaté en heure:minute (je dois aussi calculé le total de présence quotidienne).


Je viens d'essayer ceci:

=NB.SI.ENS(p_enfant1;"<3")

en sélectionnant avec CTRL toutes les cellules sur lequel je voudrais faire ma statistique et ensuite en leur donnant un nom de plage. Mais j'ai un message #VALEUR!

Je continue ma quête.
Messages postés
5
Date d'inscription
mardi 22 novembre 2011
Statut
Membre
Dernière intervention
22 novembre 2011

Je me trompe ou cette formule NB.SI.ENS est à utiliser dans le cas ou TOUS les critères doivent concorder ?
Messages postés
5
Date d'inscription
mardi 22 novembre 2011
Statut
Membre
Dernière intervention
22 novembre 2011

je continue ma recherche sur un truc qui tourne autour de

=NB(SI((c5:cq5="P")*(C6:CQ6<"3"),C6:CQ6))

trouvé sur le Net mais ... marche pas non plus.
La solution est : =NB.SI(E6;"<3" )+NB.SI(H6";<3")+....
La formule NB.SI.ENS ne te comptabilisera 1 que si apparait un chiffre <3 simultanément dans tes différentes plages non adjacentes.