Plage horaire sur Excel [Résolu/Fermé]

Signaler
-
 Sand2941 -
Bonjour,
Voilà, je gère une garderie et je voudrais créer une formule qui me simplifierai la vie :

Exemple :


NOMS Prénoms Matin
LE FUR Emma 08:10
BILLANT Théo 07:40
BALCON Timothée 07:15

Voici mon barème :
les enfants arrivant entre 7H et 7H35 doivent payer 3 1/2heure de garderie
les enfants arrivant entre 7H36 et 8H05 doivent payer 2 1/2 heure
les enfants arrivant entre 8H06 et 8H35 doivent payer1 1/2 heure

Je voudrais que dans une autre colonne, ma formule me donne
pour l'enfant LE FUR : 1
pour l'enfant BILLANT : 2
et pour l'enfant BALCON : 3

Car j'ai beaucoup d'enfants, beaucoup de jours et il y aurait une formule presque idem pour la garderie du soir mais avec 5 plages horaires (16H30/17H, 17H01/17H30, 17H31/18H, 18H01/18H30, 18H31/19H).

Est-ce que quelqu'un peut m'aider je planche dessus depuis un moment sans succès.

Merci de votre aide.

Sandrine

1 réponse

Messages postés
53349
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2021
15 369
Bonjour Sandrine.

Voila : https://www.cjoint.com/?AKirdnSryGo
Trop cool !
Merci beaucoup Raymond, ça va me faire gagner énormément de temps !

Cordialement.

Sandrine
Bonjour,

Je voudrais maintenant additionner les résultats obtenus et ça me marque #VALEUR! lorsqu'une des cellules est vide.
Est-ce qu'on peut y remédier ?
Il faut préciser que j'ai quelque peu changer la formule et mis des guillemets pour que ça ne marque rien si la cellule est vide (au lieu de 0)
Messages postés
25843
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 797
Bonjour

Sans voir le fichier, il est fort probable que ce soit le passage e 0 à "" qui engendre le défaut!cra "" est un texte qui ne paésse dans les sommes que qi elles sont définies par des limites de champ:
exemple:
=SOMME(A1:A5) fonctionne avec des "", mais =A1+A2+A3+A4+A5 renvoie #VALEUR
si vous pouvez:
en priorité1°)
, utilisez le code SOMME(champ)

sinon 2°)
revenez au 0 et pour ne pas voir les affichés:
sur excel avant 2007
Barre d'outil / Outil / Option Affichage et décochez:
afficher valeur 0
sur excel à partir de 2007:
clic sur logo Microsoft en haut à gauche
*en bas de la fenêtre: "option excel"
liste à gauche:
"options avancée"
Chercher à droite le paragraphe:
"option pour cette feuille de calcul"
et décocher:
"afficher un 0 dans les cellules qui ont une valeur nulle"

Ou 3°)
si vous voulez conservez l'option d'affichage 0 pour d'autres raisons, vous pouvez les masquer avec une mise en forme conditionnelle des cellules concernées et une police de même couleur que la cellule dans la MFC

crdlmnt
Oui c'est ça c'est le fait de passer de 0 à " " qui m'a générer une erreur, j'ai remis la formule en marquant 0 et j'ai décocher l'option d'affichage de 0.
C'est super nickel.
Merci beaucoup