Excel - Somme d'une cellule selon son nom

Résolu/Fermé
Signaler
-
 Bat_Dude -
Bonjour,
J'ai essayé de trouver ma réponse, mais en vain !
Je vous explique :
Pour faire mes comptes à la fin du mois, j'aimerais regrouper mes mêmes dépenses
rapidement grâce à leur nom.
Par exemple, sur ma 1ère colonne j'ai une dépense "SNCF" ou "Carrefour",
et sur la 2 ème colonne le total de la dépense.

Ainsi, à la fin de mes comptes, sur mon tableau des dépenses totales, j'aimerais
trouver une formule qui dise : faire la somme si le nom est : SNCF.

Avez-vous une solution?

Merci d'avance.

3 réponses

Messages postés
26403
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Bonsoir
=SOMME.SI(champ des noms; noms;champ des montants)
champ étant les limites de chacun des champs
nom étant soit le nom cherché entre guillemets, soit l'adresse de cellule où se trouve ce nom
exemple pour un champ avec les noms en A, les montants en B de ligne 2 à ligne 100:
=SOMME.SI(A2:A100;"SNCF";B2:B100)
ou
=SOMME.SI(A2:A100;C1;B2:B100) avec SNCF inscrit en C2
si vous devez tirer la formule dans un tableau récap, bloquer les champs:
=SOMME.SI($A$2:$A$100;C1;$B$2:$B$100)
vous pouvez par exemple faire en C à partir de 2 la liste des noms cherchés,placer la formule en D2 et la tirer sur la hauteur C
crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Messages postés
17822
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2022
4 914
Salut,

tu as également

=SOMMEPROD((A1:A50="SNCF")*(B1:B50))

ou dans une cellule tu saisis le texte recherché ex. SNCF ou tu crées une liste déroulante pour sélectionner le texte recherché ex en D1

=SOMMEPROD((A1:A50=D1)*(B1:B50))

tu peux également nommer les plages ex A1 à A50 nommée Text et B1 à B50 nommée Val ou valeur

ce qui donne en formule

=SOMMEPROD((Text=D4)*(Val))
0
Merci beaucoup !
0