Formule si excel

[Résolu/Fermé]
Signaler
-
Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour,


J'ai une question conçernant un tableau excel que je suis en train de créer pour mon travail.

C'est un tableau pour calcul des CP d'ancienneté.
J'ai plusieurs intervalles à prendre en compte et je n'arrive pas à trouver la bonne formule.

J'ai une colonne avec les années d'ancienneté des salariés et je dois trouver leur nombre de cp.

Pour 5 ans d'ancienneté : 1 jour
10 ans : 2 jours
15 ans : 3 jours
20 ans et plus : 4 jours

Je vous remercie d'avance pour l'aide que vous pourrez m'apporter.

1 réponse

Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
bonjour
nombre d'années présence en A1
nombre de Congés
=min(4;ent(A1/5))
Michel
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
513
Date d'inscription
dimanche 30 décembre 2007
Statut
Membre
Dernière intervention
20 novembre 2011
185
exact, c'est le plus simple :)

une formule plus compliquée serait :

=SI(A1<5;0;SI(A1<10;1;SI(A1<15;2;SI(A1<20;3;4))))
Merci beaucoup à vous, cela fonctionne parfaitement.
Rebonjour,
Encore une petite question, est ce possible de faire ressortir les résultats sans avoir à lire le tabeau à chaque fois ?
Je veux dire par là, est il possible quand j'ouvre le fichier de voir tout de suite quels salariés ont droit ce mois à un jour de CP ? Par des couleurs ? je passe par la mise en forme conditionnelle ??
Merci
Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
oui