Additionner des données de doublons (EXCEL) [Résolu/Fermé]

Signaler
-
 cel -
Bonjour,

Je dois analyser un fichier clients:
Dans ma colonne A j ai les noms de mes clients
Dans ma colonne B les segments marché auquel ils appartiennent
Dans ma colonne C le chiffre d'affaire réalisé en 2010

J'ai des doublons dans les noms des clients. Donc j'ai parfois deux, trois, voir dix chiffres d'affaire pour le même client.

J'ai mis en évidence les doublons mais je ne sais pas comment additionné AUTOMATIQUEMENT leur chiffres d'affaire. Et manuellement c'est très long de faire la formule somme à chaque fois pour chaque client..

Comment faire??!

Merci!!




4 réponses

Messages postés
12235
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
6 janvier 2021
2 558
Bonjour,
Un petit exemple pour Excel 2003.
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Bonjour:
=SOMME.SI(liste client;nom client;liste chiffre d'affaire)
pour avoir le chiffre par segment si besoin:
=SOMMEPROD(Liste client=nom client)*(liste segments=segment)*(liste des chiffres d'affaires))
"liste..." sont les adresses de champ
les noms peuvent être remplacés par des adresses de cellules où les noms cherchés seront inscrit
exemple:
de A1à A100 nom des clients
de B1à B100: liste des segments
de C1 à C100: montants des CA
en D1 nom du client
en D2 nom du segment
en E1 total CA pour le client:
SOMME.SI(A1:A100;D1;C1:C100)
et par client et segment en E2
=SOMMEPROD((A1:A100=D1)*(B1:B100=D2)*(C1:C100))

bonne chance
crdlmnt
Messages postés
23814
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 janvier 2021
6 593
Bonjour,

Comment faire??!
Faire un TCD

Sur excel 2003 : menu 'données / rapport de tableau croisé dynamique...'
Une fois créé un simple rafraichissement du tableau (icone ! rouge) met à jour tes totaux suite à une modif ou un ajout.

Au début tu tatonnes pour y arriver mais ça vaut le coup d'insister, ça te resservira.
ex : http://www.cijoint.fr/cjlink.php?file=cj201109/cijdPXQ2vQ.xls

eric
Bonjour,

Merci beaucoup pour vos réponses. J'ai Excel 2010 donc j'ai mis un peu de temps mais j'ai finalement fait un TCD et ça fonctionne j'ai obtenu la somme de mes CA!