Recherchev avec doublons

[Résolu/Fermé]
Signaler
Messages postés
25
Date d'inscription
mercredi 30 mars 2011
Statut
Membre
Dernière intervention
9 février 2013
-
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
-
Bonjour,

Je viens chercher un peu d'aide. J'ai 3 colonnes excel: La 1ère contient les 3 premières lettres de noms, la 2ème des numéros. Dans la 3ème, j'ai cette formule pour retrouver des noms complet a partir des informations des colonnes A ou B (je n'ai toujours qu'une seule information sur les 2) :

=SI(B398<>"",RECHERCHEV(B398,'BD1 !E:F,2,0),RECHERCHEV(C398,BD2!B:I,8,0))

Mon problème est que dans BD1, certains noms commencent de la même manière et il y a donc plusieurs réponses possibles. Excel me renvoie toujours le 1er résultat qu'il trouve. Y a t-il une solution pour qu'en cas de doublons, il ne me renvoie soit rien, soit toutes les réponses possibles, et que je sélectionne moi même la bonne réponse?
Merci beaucoup.

3 réponses

Messages postés
24196
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 octobre 2021
6 923
Bonjour,

Comme ton problème ne se pose pas avec les n° je commencerai la recherche par celui-ci.

Renvoyer toutes les réponses : ça serait en vba et je ne sais pas si ça vaut le coup.

=SI(ET(C2<>"";NB.SI('BD2'!B:B;C2)=1);RECHERCHEV(C2;'BD2'!B:I;8;0);SI(NB.SI('BD1'!E:E;B2)=1;RECHERCHEV(B2;'BD1'!E:F;2;0);SI(NB.SI('BD1'!E:E;B2)>1;"plusieurs noms";"")))
Si le nombre existe 1 fois, la valeur est ramenée de BD2
Sinon recherche des 3 lettres en BD1. Ramène la valeur si unique, ou "plusieurs noms" ou vide si non trouvées.

eric
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 289
Bonjour,

il existe ici une astuce sur la rechercheV polyvalente.

Cordialement.
Messages postés
25
Date d'inscription
mercredi 30 mars 2011
Statut
Membre
Dernière intervention
9 février 2013
4
Cette formule est magique! Merci beaucoup!!! :)
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 289
Merci mais c'est la personne qui a réalisé cette astuce qu'il faut remercier ^^

Vous pouvez donc passer le sujet en résolu.
Messages postés
10
Date d'inscription
mercredi 17 août 2011
Statut
Membre
Dernière intervention
16 juin 2013

remplace la deuxieme lettre par une étoile comme sa sa va te renvoyer toute les reponse possible