[PHP]POST toujours vide !

[Résolu/Fermé]
Signaler
Messages postés
69
Date d'inscription
jeudi 27 janvier 2011
Statut
Membre
Dernière intervention
24 février 2017
-
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
-
Bonjour,

Je suis en train de réaliser un formulaire d'identification en PHP. Rien de bien méchant, sauf que ma page refuse d'envoyer les données du formulaire.
Voici mon formulaire :

        	<form id="identification" name="identification" action="login.php" method="post" >
                <div class="inputcontainer">
                    <img src="./images/icons/icon_username.png" alt="Identifiant" />
                    <label for="identifiant">Identifiant:</label>
                    <input type="text" id="identifiant" />
                </div>
                <div class="inputcontainer">
                    <img src="./images/icons/icon_locked.png" alt="Mot de passe" />
                    <label for="passe">Mot de passe:</label>
                    <input type="password" id="passe" />
                </div>
                <input type="submit" value="Login" class="loginsubmit" />
                <p><a href="#">Mot de passe oublié?</a></p>
            </form>


J'ai beau tout tenter, $_POST reste toujours vide... Je suis sous MAMP PRO 1.9.4/PHP 5.2.13.

Si vous avez une idée, je suis prenant !

1 réponse

Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 137
C'est normal, tu n'as pas nommé tes input !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42584 internautes nous ont dit merci ce mois-ci

Messages postés
69
Date d'inscription
jeudi 27 janvier 2011
Statut
Membre
Dernière intervention
24 février 2017

La loose pour moi.

Merci pour l'aide ^^
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 137
Pas de mal, ça arrive ;)