[excel] recherchev avec deux valeurs cherchees

Résolu/Fermé
pilote360
Messages postés
150
Date d'inscription
vendredi 3 juin 2011
Statut
Membre
Dernière intervention
31 juillet 2015
- 24 juil. 2011 à 17:14
 alablearn - 16 oct. 2015 à 17:28
Bonjours je suis sous excel 2004 et j aimerais effectuer une recherche vertical dont la valeur cherchee serait de deux cellules

Exemple

Produit. Model. Prix.
Iphone 3. 8 Go. 550?

Les conditions "iphone 3" et "8 Go" pouvant etre modifiees

J aimerais donc que en fontion du produit et de son model le prix correspondent

Merci a vous et n esitez pas a me poser des questions si je me suis
Mal expliquer


A voir également:

7 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 269
24 juil. 2011 à 19:04
Bonsoir
formule selon exemple à adapter:
De A1 à A100 les produits
De B1 à B100 les modèles
de C1 à C100 le prix

en D1 produit cherché
en E1 modèle cherché
en f1 la formule:
=INDEX(C1:C100;EQUIV(D1&E1;A1:A100$B1:B100;0);1)
formule matricielle à entrer avec la touche enter et crtl + shift enfoncées
(elle doit se retrouver entre accolades dans la barre de formule.)

ou alors, si le produit et le modèle n'existent que sur une ligne:
=SOMMEPROD(A1:A100=D1)*(B1:B100=C1)*(C1:C100))
à entrer de manière standard.

crdlmnt
3
Attention il y a des erreurs dans les deux formules, les versions correctes sont :

=INDEX(C1:C100;EQUIV(D1&E1;A1:A100&B1:B100;0);1)
puis Ctrl+Shift+Enter
(& au lieu de $)

=SOMMEPROD((A1:A100=D1)*(B1:B100=C1)*(C1:C100))
puis Enter
(1ère parenthèse manquante)
0
merci infiniment Vaucluse (et aze3249 pour ta correction) ta formule marche a merveille
0