Installation cacti ubuntu

Résolu
Bonjour,

je suis entrain d'installer cacti sur ubuntu par paquet et durant l'installation une fenêtre apparaît "libphp-adodb n'est plus installé dans /usr/share/adodb. Le nouveau chemin d'installation (« include path » pour php) est maintenant /usr/share/php/adodb.

Veuillez mettre à jour votre fichier php.ini. Par ailleurs, vous devrez peut-être également modifier la configuration de votre serveur web."

que faut-il faire ?

merci d'avance

11 réponses

  1. bonsoir à tous,

    j'ai trouvé la solution il suffit de relancer le poller toute les 5 minutes via une tâche cron en claire à la fin du fichier cacti dans /ect/cron.d/ ajouter cette ligne :

    */5 * * * * www-data php /var/www/cacti/poller.php > /dev/null 2>&1

    pour une installation complète de cacti :

    http://wiki.monitoring-fr.org/integration/cacti/ubuntu-install

    cordialement
    1. Modérateur
      Tu as suivi ce tutoriel ?
      http://doc.ubuntu-fr.org/cacti

      Est-ce que ton système est à jour ?

      sudo apt-get update
      sudo apt-get install aptitude
      sudo aptitude update
      sudo aptitude safe-upgrade


      Bonne chance
      1. bonjour et merci de ton aide,

        j'ai réussi à installer cacti mais il n'y a aucun graphique.
        Comment configurer cacti ?

        merci d'avance
        1. Modérateur
          L'interface graphique de cacti est accessible via ton navigateur web (firefox, chromium, konqueror...). Tu ne parviens pas à y accéder ?
          1. je peux accéder à l'interface graphique quand je parlais de graphique je parlais des graphiques système comme sur les captures d'écran
            1. Modérateur
              Tu as installé rrdtools comme indiqué dans la doc ? Personnellement je ne connais pas trop cacti jusqu'ici j'ai plutôt utilisé munin qui lui aussi se base sur rrdtools pour autant que je me souvienne...
              1. bonsoir et merci de votre aide,

                rddtools est bien installé mais les graphes ne s'affichent pas
                1. bonsoir,

                  les pistes ne donnent rien voici le log de cacti :

                  Log File [Total Lines: 8 - All Items Shown]
                  07/20/2011 07:19:21 PM - AUTH LOGIN: User 'admin' Authenticated
                  07/19/2011 10:20:10 PM - CMDPHP: Poller[0] ERROR: SQL Cell Failed!, Error:'1064', SQL:"select xml_path from snmp_query where id="
                  07/19/2011 10:17:38 PM - AUTH LOGIN: User 'admin' Authenticated
                  07/18/2011 08:06:07 PM - AUTH LOGIN: User 'admin' Authenticated
                  07/18/2011 08:04:40 PM - AUTH LOGIN: User 'admin' Authenticated
                  07/18/2011 08:03:53 PM - CMDPHP: Poller[0] ERROR: A DB Exec Failed!, Error:'1062', SQL:"INSERT INTO user_log (username,user_id,result,ip,time) VALUES ('admin',0,0,'127.0.0.1',NOW())'
                  07/18/2011 08:03:53 PM - CMDPHP: Poller[0] ERROR: A DB Exec Failed!, Error:'1062', SQL:"INSERT INTO user_log (username,user_id,result,ip,time) VALUES ('admin',0,0,'127.0.0.1',NOW())'
                  07/18/2011 08:00:00 PM - CMDPHP: Poller[0] ERROR: A DB Exec Failed!, Error:'1062', SQL:"INSERT INTO user_log (username,user_id,result,ip,time) VALUES ('admin',0,0,'127.0.0.1',NOW())'
                  1. Modérateur
                    Bah pourtant le message indique clairement que le poller n'arrive pas à introduire de données dans la base de données. Donc vérifie que ton serveur de base de données est configuré, que le profil pour cacti est configuré etc...

                    Bonne chance
                    1. Modérateur
                      Parfait merci pour ces précision. Ainsi c'était simplement la sonde qui n'était pas invoquée periodiquement. Dommage que cacti ne le fasse pas automatiquement, c'est un mécanisme qui est pourtant prévu par exemple dans munin.