Valeur d'erreur #DIV/0 [Résolu/Fermé]

Signaler
Messages postés
144
Date d'inscription
mercredi 27 octobre 2010
Statut
Membre
Dernière intervention
24 avril 2019
-
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
-
Bonjour,

J'ai crée un classeur qui me permet de calculé la variation du résultat d'un mois à l'autre.

Pour être plus explicité j'ai ceci:

Résultat Janvier; résultat Février, Résultat Mars, résultat Avril,.....

Les variations que je souhaite:

Variation en février : (Résultat Février - Résultat janvier)/ Résultat Janvier

Mon problème est que si le Dénominateur(résultat Janvier=0) ça renvoie #DIV/0.

Par exemple: résultat janvier = 0; résultat Février= 10 on a:

variation Février = (10-0)/0 = #DIV/10 au lieu de variation 100%.
Pourtant le résultat de janvier peut bien être 0.

Je vous sollicite votre aide. trouvez ci joint mon fichier:https://www.cjoint.com/?AGbnIGgbLjd

Bonisam


5 réponses

Messages postés
7389
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
24 juillet 2020
3 027
salut
=SI(A1=0;"0";(B1-A1)/A1)
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 236
Passer de 0 à 10 pour toi ça fait une variation de 100% ? Oo ya pas comme un petit problème ?
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 795
En C17, commence ta formule
=SI(ET(C15<B15;((C15-B15)/B15)<0);((C15-B15)/B15);-((C15-B15)/B15))
avec le test pour voir si B15 est nul
=SI(B15=0;""; =SI(ET(C15<B15;((C15-B15)/B15)<0);((C15-B15)/B15);-((C15-B15)/B15)) )

Par ailleurs, je n'ai rien compris à la complexité de ta formule pour le choix des signes ; quelle règle veux-tu appliquer ?
Si la variation peut être positive ou négative, il suffit d'utiliser la formule
=SI(B15=0;"";(C15-B15)/B15)
Si la variation doit être affichée en valeur absolue, la formule sera
=ABS(SI(B15=0;"";(C15-B15)/B15))

Tu n'es pas de mon avis ?
Messages postés
144
Date d'inscription
mercredi 27 octobre 2010
Statut
Membre
Dernière intervention
24 avril 2019

Re;

Raymond;

En fait le signe pose problème. Prenons un exemple simple:

Résultat janvier= -50

Résultat février= -100

Donc vous voyez que le résultat février< résultat Janvier donc on doit avoir une variation négative en février puisse que le résultat décroit.

Mais en calcul numérique on : [-100-(-50)]/-50 = 1 *100= 100% au lieu de -100%.

J'ai retenue votre formule suivante:
SI(B15=0;"";SI(ET(C15<B15;((C15-B15)/B15)<0);((C15-B15)/B15);-((C15-B15)/B15)))

Par ailleurs, je fais un clin d'oeil à chossette9 qui a attiré mon attention que passer de 0 à 10 n'est effectivement pas une variation de 100%.

Merci à tous!
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 795
Alors je proposerais
=SI(B15=0;"";(C15-B15)/B15)*SIGNE(B15)