Excel ou Word (2007) "comparer" deux listes

Résolu/Fermé
Judagaga - 17 juin 2011 à 18:39
 Judagaga - 17 juin 2011 à 20:53
Bonsoir,
.

Je dispose de Microsoft Office 2007.
.
J'aimerai savoir s'il existe un moyen de comparer 2 listes de noms, afin que excel me mette en évidence les différences.
.
Je vais essayer de m'expliquer à travers un exemple
.
j'ai 2 listes (où vous voulez, soit sur 2 colonnes différentes, soit sur une autre feuille, soit sur un autre document)
.
.
première liste:
.
Antoine
Benoit
Caroline
Delphine
Elodie
Frédérique
Gérard
.
.

deuxième liste:
.
Antoine
Delphine
Elodie
Gérard
.
.
.


j'aimerai savoir s'il existe un moyen, sur excel (ou sur word peut-être?), qui me permettrait de savoir que dans la seconde liste, il me manque Benoit, Caroline, Frédérique
.
.
.
Merci d'avance





2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
Modifié par Vaucluse le 17/06/2011 à 18:54
Bonjour
Sur excel,il y a des moyens d'identifier ce qui n'est pas dans l'autre liste
avec une formule dans une colonne contiguë:
pour une colonne liste 1 en A, à placer en colonne B et à tirer sur la hauteur:
=SI(NB.SI(liste 2;A1)>0;"présent";"absent")

avec une MFC mise en forme conditionnelle:
sélectionnez la liste 1
onglet du ruban >Accueil
Mise en forme conditionnelle/nouvelle régle/ Utiliser une formule et:
=NB.SI(liste 2;A1)>0
format / choisissez un fond de couleur et fermez.
les cellules de liste 1 comportant des noms existant en liste 2 prendrons la couleur choisie.
avec NB.SI(Liste 2;A1)=0 ce sont les noms manquants qui prendrons la couleur

Note: si vos listes sont sur deux feuilles différentes, la MFC exige que le champ de recherche soit nommé:
sélectionnez liste 2
Onglet du ruban > formules / Définir un nom / Donnez un nom (par exemple LISTE_1... (sans blanc))
la formule de MFC devient:
=NB.SI(LISTE_1;A1)>0

crdlmnt

Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
1
Merci pour cette réponse, qui semble correspondre exactement à ce que je souhaite faire.

Seulement je ne comprend pas très bien ce que je dois faire.


pour une colonne liste 1 en A, à placer en colonne B et à tirer sur la hauteur:
=SI(NB.SI(liste 2;A1)>0;"présent";"absent")

que voulez-vous dire par "à tirer sur la hauteur" ?

la liste 1 est à placer en A ou en B?





pour la suite, il me parle d'une erreur dans cette formule
=NB.SI(liste 2;A1)>0


surement parce que j'ai raté la première étape ...
1
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
17 juin 2011 à 19:55
Prendre la colonne B pour la formule n'était peut être pas le,plus facile à comprendre
Alors, un exemple à adapter
Liste 1 de A1à A100
Liste B de B1à B50
en C1, la formule:
=SI(NB.SI($B$1:$B$50;A1)>0;"présent";"absent")
attention aux signes
une fois la formule entrée en C1 sélectionnez la cellule,maintenez le clic sur le petit carré noir en bas à gauche. lorsque la croix apparaît et faites glisser vers le bas jusqu'au bout de la liste en A pour recopier la formule
pour la MFC:
sélectionnez le champ A1:A100
suivez le process indiqué dans le message précédent et entrez la formule:
=NB.SI($B$1:$B$50;A1)=0
choisissez la couleur.
bonne chance
crdlmnt
0
J'ai tout compris, et ça marche, merci beaucoup!

je vous souhaite une excellente soirée

Cordialement
0