Fonction décaler excel sur plusieurs cellules [Résolu/Fermé]

Signaler
-
 loris18 -
Bonjour,
je veux saisir la valeur 1 mais uniquement une fois :soit en A2 ou B2 ou C2 ou A4 ou B4 ou C4 et reporter la valeur du dessus dans D1 par ex.
EX: si je mets 1 en B4 :Pduit y doit s'afficher.
A B C
1 Pduit u PDUIT v Pduit w
2
3 Pduit x Pduit y Pduit z
4
je sais qu'il faut utiliser Décaler mais il y a beaucoup de données.
merci pour votre aide

1 réponse

Messages postés
16292
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
11 novembre 2020
3 064
Bonjour

essaies par "indirect"
=SI(NB.SI(A2:C4;1)<>1;"";INDIRECT(ADRESSE(SOMMEPROD(($A$2:$C$4=1)*LIGNE($A$2:$C$4))-1;SOMMEPROD(($A$2:$C$4=1)*COLONNE($A$2:$C$4)))))  


et aussi par "decaler"
=SI(NB.SI(A2:C4;1)<>1;"";DECALER(A1;SOMMEPROD(($A$2:$C$4=1)*LIGNE($A$2:$C$4))-2;SOMMEPROD(($A$2:$C$4=1)*COLONNE($A$2:$C$4))-1))

Michel
merci beaucoup ça marche