Excel Somme d'une plage si [Résolu/Fermé]

Signaler
Messages postés
188
Date d'inscription
dimanche 19 avril 2009
Statut
Membre
Dernière intervention
12 juin 2020
-
Messages postés
188
Date d'inscription
dimanche 19 avril 2009
Statut
Membre
Dernière intervention
12 juin 2020
-
Bonjour,

Je souhaiterais savoir si il est possible d'effectuer la somme d'une plage de valeur avec comme condition la une cellule de la collonne A

En fait j'ai un certain nombre de coût par element chaque element est designés par un chiffre en collonne à je voulais sommer les elemments de chaque ligne comportant le nom de la machine en colonne A pour savoir combien m'a couté l'element..

Heu c'est pas tres clair

A B C D
174 2€ 5€ 10€
175 6€ 5€ 11€
173 2€ 9€ 16€
174 8€ 7€ 10€
174 2€ 5€ 10€
173 2€ 5€ 10€
174 2€ 5€ 10€
174 2€ 5€ 10€

J'avais pense a un test logique mais comment dire si 174 se touve dans la plage A:A somme les ligne erf de la plage B:D

Dans l'attente de vous lire Merci

1 réponse

Messages postés
25852
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mars 2021
5 802
Bonjour
deux options:
1° formule matricielle à entrer en maintenant les touches shift et ctrl enfoncées
=SOMME(SI(A:A=174;B:D))
la formule doit se retrouver affichée entre accolades dans la barre de formule

Attention, si la formule n'est pas entrée avec cette méthode, elle donne la somme totale du tableau

2° en normal:
plus long, mais pas de risque d'erreur
=SOMME.SI(A:A;174:B:B)+SOMME.SI(A:A;174;CC)+SOMME.SI(A:A;174;D:D)

bien entendu 174 peut être remplacé dans les deux cas par une adresse de cellule où la valeur cherchée sera placée.

crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
Messages postés
188
Date d'inscription
dimanche 19 avril 2009
Statut
Membre
Dernière intervention
12 juin 2020
1
Merci pour ta reponse rapide Vaucluse
Je n'ai pas reussi a faire fonctionner la 1er formule qui est bien plus simple j'ai bien les {} qui encadre la formule en validant par MAj CTRL entrée mais cela me renvoi une erreur NOMBRE

L'autre fonctionne a merveille c'est parfait
Messages postés
25852
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mars 2021
5 802
et pourtant elle tourne!!!:

http://www.cijoint.fr/cjlink.php?file=cj201105/cijk5gyGpg.xls

l'essentiel étant que vous ayez trouvé une solution

bonne route
Messages postés
188
Date d'inscription
dimanche 19 avril 2009
Statut
Membre
Dernière intervention
12 juin 2020
1
Super la formule fonctionne nikel j'ai juste des doight capricieux...

J'aurais une autre question du meme type une formule du style
{=SOMME(SI(($E$2:$E$4097=$Z3)*($H$2:$H$4097=$AB$2);1;0))}

Je compte donc les occurences des critere Z3 et AB2 dans leurs plage respective je souhaiterais ajouter un critere mais cette fois du style

Compter le nombre d'occurence de Z3 en E2:E4097 et (AB2 ou "Toto" sur la meme plage en l'occurence H2:H4097)...

Je sais pas si c'es tres clair en fait additionner ces deux formules

{=SOMME(SI(($E$2:$E$4097=$Z3)*($H$2:$H$4097=$AB$2);1;0)) + SOMME(SI(($E$2:$E$4097=$Z3)*($H$2:$H$4097="Toto");1;0))}

J'ai fait comme ça et cela fonctionne Nikel donc je vait tenter de tourner 10 fois les formules dans ma tite tete avant de poser une question...

Dans l'attente de te lire Merci encore